diff mbox series

[bug#40104,v2] gnu: Add emacs-org-static-blog.

Message ID 20200318082443.25193-1-brice@waegenei.re
State Accepted
Headers show
Series [bug#40104,v2] gnu: Add emacs-org-static-blog. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Brice Waegeneire March 18, 2020, 8:24 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-org-static-blog): New variable.
---
 gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Comments

Jack Hill March 18, 2020, 5:15 p.m. UTC | #1
I know this was already merged, but I found an additional nit-pick/typo:

On Wed, 18 Mar 2020, Brice Waegeneire wrote:

> +    (description
> +     "@code{emacs-org-static-blog} is one more static blog generator, it focuses on being
> +simple.  All file are simple Org files in a directory.  The only requirement

I believe it should read, "All files are simple Org files…". Note the lack 
of s on the first instance of file.

Hopefully you don't mind me pointing out such a small thing.

All the best,
Jack
Nicolas Goaziou March 18, 2020, 8:51 p.m. UTC | #2
Hello,

Jack Hill <jackhill@jackhill.us> writes:

> I believe it should read, "All files are simple Org files…". Note the
> lack of s on the first instance of file.
>
> Hopefully you don't mind me pointing out such a small thing.

Not at all!

Fixed. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d45814379b..e09eb4a19f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -62,6 +62,7 @@ 
 ;;; Copyright © 2020 Evan Straw <evan.straw99@gmail.com>
 ;;; Copyright © 2020 Masaya Tojo <masaya@tojo.tokyo>
 ;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
+;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -21806,3 +21807,30 @@  All entries in a specified TODO state will be carried over to the next day.")
        "Daredevil SKK is a version of @acronym{SKK, Simple Kana to Kanji
 conversion program}, a Japanese input method on Emacs.")
       (license license:gpl2+))))
+
+(define-public emacs-org-static-blog
+  ;; Use the latest commit as the last release only contains half of the
+  ;; current total commits.
+  (package
+    (name "emacs-org-static-blog")
+    (version "20200117")
+    (home-page "https://github.com/bastibe/org-static-blog")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url home-page)
+             (commit "5c19300d7634e94ae813b1b66abc716fbb1e5fc9")))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1m7vmibjc6yk2npfrnnqd3g2099300r0q8mr8cvyivmk5ailbfrh"))))
+    (build-system emacs-build-system)
+    (synopsis
+     "Simple Org mode based static blog generator")
+    (description
+     "@code{emacs-org-static-blog} is one more static blog generator, it focuses on being
+simple.  All file are simple Org files in a directory.  The only requirement
+is that every Org file must have a @samp{title} and a @samp{date} keywords,
+and optionally, a @samp{filetags} keyword.")
+    (license license:bsd-3)))