diff mbox series

[bug#40104,1/1] gnu: Add emacs-org-static-blog.

Message ID 20200317141253.25851-2-brice@waegenei.re
State Accepted
Headers show
Series Add emacs-org-static-blog | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Brice Waegeneire March 17, 2020, 2:12 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-org-static-blog): New variable.
---
 gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

Nicolas Goaziou March 17, 2020, 3:07 p.m. UTC | #1
Hello,

Brice Waegeneire <brice@waegenei.re> writes:

> * gnu/packages/emacs-xyz.scm (emacs-org-static-blog): New variable.

Thank you.

> +(define-public emacs-org-static-blog
> +  (package
> +   (name "emacs-org-static-blog")
> +   (version "20200117.800")

Could you explain in a comment why using an unstable release is
required?

> +   (source
> +    (origin
> +     (method url-fetch)
> +     (uri (string-append
> +           "https://melpa.org/packages/org-static-blog-"
> +           version ".el"))

It seems upstream is at Github, not MELPA. Could you use Github instead?

> +   (home-page
> +    "https://github.com/bastibe/org-static-blog")
> +   (synopsis
> +    "Simple org-mode based static blog generator")

Nitpick: Simple Org mode based static blog generator

> +   (description
> +    "Org-static-blog is one more static blog generator, it focuses on being
> +simple.  All files are simple org-mode files in a directory.  

Nitpick: All file are simple Org files in a directory.

> The only
> +requirement is that every org file must have a #+TITLE and a #+DATE, and
> +optionally, #+FILETAGS.")

Nitpick: every Org file must have a @samp{title} and a @samp{date}
keywords, and optionally, a @samp{filetags} keyword.

Could you send an updated patch?

Regards,
Brice Waegeneire March 18, 2020, 8:26 a.m. UTC | #2
On 2020-03-17 15:07, Nicolas Goaziou wrote:
> Hello,
> 
> Brice Waegeneire <brice@waegenei.re> writes:
> 
>> * gnu/packages/emacs-xyz.scm (emacs-org-static-blog): New variable.
> 
> Thank you.
> 
>> +(define-public emacs-org-static-blog
>> +  (package
>> +   (name "emacs-org-static-blog")
>> +   (version "20200117.800")
> 
> Could you explain in a comment why using an unstable release is
> required?
> 
>> +   (source
>> +    (origin
>> +     (method url-fetch)
>> +     (uri (string-append
>> +           "https://melpa.org/packages/org-static-blog-"
>> +           version ".el"))
> 
> It seems upstream is at Github, not MELPA. Could you use Github 
> instead?
> 
>> +   (home-page
>> +    "https://github.com/bastibe/org-static-blog")
>> +   (synopsis
>> +    "Simple org-mode based static blog generator")
> 
> Nitpick: Simple Org mode based static blog generator
> 
>> +   (description
>> +    "Org-static-blog is one more static blog generator, it focuses on 
>> being
>> +simple.  All files are simple org-mode files in a directory.
> 
> Nitpick: All file are simple Org files in a directory.
> 
>> The only
>> +requirement is that every org file must have a #+TITLE and a #+DATE, 
>> and
>> +optionally, #+FILETAGS.")
> 
> Nitpick: every Org file must have a @samp{title} and a @samp{date}
> keywords, and optionally, a @samp{filetags} keyword.
> 
> Could you send an updated patch?
> 
> Regards,
V2 send with all your suggestions added. And I have requested a new 
release upstream: https://github.com/bastibe/org-static-blog/issues/50
Nicolas Goaziou March 18, 2020, 11:28 a.m. UTC | #3
Hello,

Brice Waegeneire <brice@waegenei.re> writes:

> V2 send with all your suggestions added. And I have requested a new
> release upstream: https://github.com/bastibe/org-static-blog/issues/50

Great! Applied as 382ba7bad59ec7205cd883bb93b5e6cf33329d66.

Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d45814379b..dfcf283283 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -62,6 +62,7 @@ 
 ;;; Copyright © 2020 Evan Straw <evan.straw99@gmail.com>
 ;;; Copyright © 2020 Masaya Tojo <masaya@tojo.tokyo>
 ;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
+;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -21806,3 +21807,28 @@  All entries in a specified TODO state will be carried over to the next day.")
        "Daredevil SKK is a version of @acronym{SKK, Simple Kana to Kanji
 conversion program}, a Japanese input method on Emacs.")
       (license license:gpl2+))))
+
+(define-public emacs-org-static-blog
+  (package
+   (name "emacs-org-static-blog")
+   (version "20200117.800")
+   (source
+    (origin
+     (method url-fetch)
+     (uri (string-append
+           "https://melpa.org/packages/org-static-blog-"
+           version ".el"))
+     (sha256
+      (base32
+       "0k1p43pvjvfzgqigybizg9pr8r7sqapbv18vhfg9smik09sjh0gd"))))
+   (build-system emacs-build-system)
+   (home-page
+    "https://github.com/bastibe/org-static-blog")
+   (synopsis
+    "Simple org-mode based static blog generator")
+   (description
+    "Org-static-blog is one more static blog generator, it focuses on being
+simple.  All files are simple org-mode files in a directory.  The only
+requirement is that every org file must have a #+TITLE and a #+DATE, and
+optionally, #+FILETAGS.")
+   (license license:bsd-3)))