diff mbox series

[bug#40066] gnu: add premake5.

Message ID 20200315005236.3031-1-leo.prikler@student.tugraz.at
State Accepted
Headers show
Series [bug#40066] gnu: add premake5. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Leo Prikler March 15, 2020, 12:52 a.m. UTC
* gnu/packages/build-tools.scm (premake5): New variable.
---
 gnu/packages/build-tools.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Marius Bakke March 20, 2020, 6:10 p.m. UTC | #1
Leo Prikler <leo.prikler@student.tugraz.at> writes:

> * gnu/packages/build-tools.scm (premake5): New variable.

Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index 63dc72e1a7..816eb6c8fe 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -245,6 +245,31 @@  other lower-level build files.")
     (home-page "https://premake.github.io")
     (license license:bsd-3)))
 
+(define-public premake5
+  (package
+    (inherit premake4)
+    (version "5.0.0-alpha14")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/premake/premake-core/"
+                                  "releases/download/v" version
+                                  "/premake-" version "-src.zip"))
+              (sha256
+               (base32
+                "0236s7bjvxf7x1l5faywmfzjywflpx42ngyhkn0mqqjnh54a97vw"))))
+    (arguments
+     (substitute-keyword-arguments (package-arguments premake4)
+       ((#:phases phases)
+        `(modify-phases ,phases
+           (replace 'install
+             (lambda* (#:key outputs #:allow-other-keys)
+               (install-file "../../bin/release/premake5"
+                             (string-append (assoc-ref outputs "out") "/bin"))
+               #t))))))
+    (description "@code{premake5} is a command line utility that reads a
+scripted definition of a software project and outputs @file{Makefile}s or
+other lower-level build files.")))
+
 (define-public osc
   (package
     (name "osc")