diff mbox series

[bug#40065] gnu: dehydrated: Declare cURL's native search paths.

Message ID 20200315002556.12076-1-me@tobias.gr
State Accepted
Headers show
Series [bug#40065] gnu: dehydrated: Declare cURL's native search paths. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Deslauriers, Douglas via Guix-patches" via March 15, 2020, 12:25 a.m. UTC
* gnu/packages/tls.scm (dehydrated)[native-search-paths]: Use curl's.
---

Posted because I'm not sure what the worst way to handle the recursion
is.  Or why it happens.

Kind regards,

T G-R

 gnu/packages/tls.scm | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)

Comments

Ludovic Courtès March 24, 2020, 5:50 p.m. UTC | #1
Tobias Geerinckx-Rice <me@tobias.gr> skribis:

> * gnu/packages/tls.scm (dehydrated)[native-search-paths]: Use curl's.

LGTM!

> Posted because I'm not sure what the worst way to handle the recursion
> is.  Or why it happens.

Recursion is expected here: loading tls.scm would require loading curl’s
module first, which itself depends on tls.scm.

Ludo’.
Maxim Cournoyer Aug. 3, 2021, 7:49 p.m. UTC | #2
Hi!

Ludovic Courtès <ludo@gnu.org> writes:

> Tobias Geerinckx-Rice <me@tobias.gr> skribis:
>
>> * gnu/packages/tls.scm (dehydrated)[native-search-paths]: Use curl's.
>
> LGTM!
>
>> Posted because I'm not sure what the worst way to handle the recursion
>> is.  Or why it happens.
>
> Recursion is expected here: loading tls.scm would require loading curl’s
> module first, which itself depends on tls.scm.
>
> Ludo’.

Pushed with commit 77e2df870bdd3605925b78642661e252a83b2369.

Closing.

Maxim
diff mbox series

Patch

diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index c8eea9c928..1cd6487e4a 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -10,7 +10,7 @@ 
 ;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
 ;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2017, 2018, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2017 Rutger Helling <rhelling@mykolab.com>
 ;;; Copyright © 2018 Clément Lassieur <clement@lassieur.org>
 ;;;
@@ -988,6 +988,13 @@  coding footprint.")
     (native-inputs
      `(("gzip" ,gzip)
        ("tar" ,tar)))
+    (native-search-paths
+     ;; XXX Using (package-native-search-paths curl) here recurses infinitely.
+     (list (search-path-specification
+            (variable "CURL_CA_BUNDLE")
+            (file-type 'regular)
+            (separator #f)
+            (files '("etc/ssl/certs/ca-certificates.crt")))))
     (home-page "https://dehydrated.io/")
     (synopsis "Let's Encrypt/ACME client implemented as a shell script")
     (description "Dehydrated is a client for signing certificates with an