diff mbox series

[bug#40050] gnu: Add ghcid.

Message ID 20200313061755.1853-1-brown121407@posteo.ro
State Accepted
Headers show
Series [bug#40050] gnu: Add ghcid. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Alexandru-Sergiu Marton March 13, 2020, 6:17 a.m. UTC
From: Alexandru-Sergiu Marton <brown121407@member.fsf.org>

* gnu/packages/haskell-apps.scm (ghcid): New variable.
---
 gnu/packages/haskell-apps.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)

Comments

Marius Bakke March 20, 2020, 6:41 p.m. UTC | #1
brown121407@posteo.ro writes:

> * gnu/packages/haskell-apps.scm (ghcid): New variable.

This was pushed in eea58169fb519c392ff3ba4a1ad5730e3be9ff39, closing!
diff mbox series

Patch

diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index 6005816260..58552666f1 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -266,6 +266,40 @@  unique algebra of patches called @url{http://darcs.net/Theory,Patchtheory}.
 @end enumerate")
     (license license:gpl2)))
 
+(define-public ghcid
+  (package
+    (name "ghcid")
+    (version "0.8.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://hackage.haskell.org/package/ghcid/" ;
+                           "ghcid-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1b8a8mx6z2ridw79gijjv90b2jgk0qrncvg0sjbmvyyyajx1h5f7"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-extra" ,ghc-extra)
+       ("ghc-ansi-terminal" ,ghc-ansi-terminal)
+       ("ghc-cmdargs" ,ghc-cmdargs)
+       ("ghc-fsnotify" ,ghc-fsnotify)
+       ("ghc-terminal-size" ,ghc-terminal-size)))
+    (native-inputs
+     `(("ghc-tasty" ,ghc-tasty)
+       ("ghc-tasty-hunit" ,ghc-tasty-hunit)))
+    (home-page
+     "https://github.com/ndmitchell/ghcid#readme")
+    (synopsis "GHCi based bare bones IDE")
+    (description
+     "Either \"GHCi as a daemon\" or \"GHC + a bit of an IDE\".  A very simple Haskell
+development tool which shows you the errors in your project and updates them whenever
+you save.  Run @code{ghcid --topmost --command=ghci}, where @code{--topmost} makes the
+window on top of all others (Windows only) and @code{--command} is the command to start
+GHCi on your project (defaults to @code{ghci} if you have a @file{.ghci} file, or else
+to @code{cabal repl}).")
+    (license license:bsd-3)))
+
 (define-public git-annex
   (package
     (name "git-annex")