diff mbox series

[bug#40042] gnu: ghc-extra: Update to 1.7.1.

Message ID 20200312152016.3910-1-brown121407@posteo.ro
State Accepted
Headers show
Series [bug#40042] gnu: ghc-extra: Update to 1.7.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Alexandru-Sergiu Marton March 12, 2020, 3:20 p.m. UTC
From: Alexandru-Sergiu Marton <brown121407@member.fsf.org>

* gnu/packages/haskell-xyz.scm (ghc-extra): Update to 1.7.1.
---
 gnu/packages/haskell-xyz.scm | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

Comments

Marius Bakke March 20, 2020, 6:49 p.m. UTC | #1
brown121407@posteo.ro writes:

> From: Alexandru-Sergiu Marton <brown121407@member.fsf.org>
>
> * gnu/packages/haskell-xyz.scm (ghc-extra): Update to 1.7.1.

Note that we follow the Stackage LTS releases to ensure the various
Haskell packages work nicely together.  The latest Stackage release of
Extra is 1.6.21, as reported by 'guix refresh':

$ ./pre-inst-env guix refresh ghc-extra
following redirection to `https://www.stackage.org/lts'...
following redirection to `https://www.stackage.org/lts-15.4'...
gnu/packages/haskell-xyz.scm:3777:13: warning: 1.7.1 is greater than the latest known version of ghc-extra (1.6.21)

So I wonder if we should downgrade this package to avoid compatibility
problems.  Thoughts?

By the way, if you use './pre-inst-env guix refresh -u PACKAGE-NAME' to
update packages, it will choose the correct version for you.
Alexandru-Sergiu Marton March 20, 2020, 7:11 p.m. UTC | #2
On Fri, 2020-03-20 at 19:49 +0100, Marius Bakke wrote:
> Note that we follow the Stackage LTS releases to ensure the various
> Haskell packages work nicely together. 

Oh. Sorry, didn't know that.

> So I wonder if we should downgrade this package to avoid
> compatibility
> problems.  Thoughts?

I upped it because ghcid 0.8.5 (latest) depends on extra >=1.6.20 and I
just thought to get the latest version available. Downgrading ghc-extra 
to 1.6.21 shouldn't break anything. If it's alright, I'll send in a
patch.

> By the way, if you use './pre-inst-env guix refresh -u PACKAGE-NAME'
> to
> update packages, it will choose the correct version for you.

Thanks for the tips!
Marius Bakke March 20, 2020, 7:15 p.m. UTC | #3
Alexandru-Sergiu Marton <brown121407@posteo.ro> writes:

> On Fri, 2020-03-20 at 19:49 +0100, Marius Bakke wrote:
>> Note that we follow the Stackage LTS releases to ensure the various
>> Haskell packages work nicely together. 
>
> Oh. Sorry, didn't know that.

No worries, very few people do!  :-)

>> So I wonder if we should downgrade this package to avoid
>> compatibility
>> problems.  Thoughts?
>
> I upped it because ghcid 0.8.5 (latest) depends on extra >=1.6.20 and I
> just thought to get the latest version available. Downgrading ghc-extra 
> to 1.6.21 shouldn't break anything. If it's alright, I'll send in a
> patch.

That sounds excellent, thank you!
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index e368082c03..418eb7cc46 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -3774,7 +3774,7 @@  versions of GHC (i.e., < 6.10).")
 (define-public ghc-extra
   (package
     (name "ghc-extra")
-    (version "1.6.18")
+    (version "1.7.1")
     (source
      (origin
        (method url-fetch)
@@ -3784,12 +3784,13 @@  versions of GHC (i.e., < 6.10).")
              ".tar.gz"))
        (sha256
         (base32
-         "0jvd4l0hi8pf5899pxc32yc638y0mrc357w0rph99k3hm277i0cy"))))
+         "0zshxv9dnd8vksncmb8dj4wvq2wdybzwxyhmy2zp6a81icm4azx4"))))
     (build-system haskell-build-system)
     (inputs
      `(("ghc-clock" ,ghc-clock)
        ("ghc-semigroups" ,ghc-semigroups)
-       ("ghc-quickcheck" ,ghc-quickcheck)))
+       ("ghc-quickcheck" ,ghc-quickcheck)
+       ("ghc-quickcheck-instances" ,ghc-quickcheck-instances)))
     (home-page "https://github.com/ndmitchell/extra")
     (synopsis "Extra Haskell functions")
     (description "This library provides extra functions for the standard