diff mbox series

[bug#40041] gnu: ghc-extra: Update to 1.7.1.

Message ID 20200312151415.3695-1-brown121407@member.fsf.org
State Accepted
Headers show
Series [bug#40041] gnu: ghc-extra: Update to 1.7.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Alexandru-Sergiu Marton March 12, 2020, 3:14 p.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-extra): Update to 1.7.1.
---
 gnu/packages/haskell-xyz.scm | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

Comments

Leo Famulari March 12, 2020, 6:13 p.m. UTC | #1
On Thu, Mar 12, 2020 at 05:14:15PM +0200, Alexandru-Sergiu Marton wrote:
> * gnu/packages/haskell-xyz.scm (ghc-extra): Update to 1.7.1.

Thanks! Pushed as b431f6c9ccfa104811dc0697d6fec84bf8b08035
Brett Gilio July 25, 2020, 1:58 a.m. UTC | #2
close 40041
Ricardo Wurmus July 25, 2020, 2:35 a.m. UTC | #3
Leo Famulari <leo@famulari.name> writes:

> On Thu, Mar 12, 2020 at 05:14:15PM +0200, Alexandru-Sergiu Marton wrote:
>> * gnu/packages/haskell-xyz.scm (ghc-extra): Update to 1.7.1.
>
> Thanks! Pushed as b431f6c9ccfa104811dc0697d6fec84bf8b08035

I know I’m a few months late, but I think the update may have been
incorrect, as it is not aligned with the rest of our Haskell packages.
We should aim to keep all Haskell packages at the same LTS release.  As
you can see here, version 1.7.1 does not correspond to any LTS release:

    https://www.stackage.org/package/extra/snapshots
Brett Gilio July 25, 2020, 8:06 p.m. UTC | #4
Ricardo Wurmus <rekado@elephly.net> writes:

> Leo Famulari <leo@famulari.name> writes:
>
>> On Thu, Mar 12, 2020 at 05:14:15PM +0200, Alexandru-Sergiu Marton wrote:
>>> * gnu/packages/haskell-xyz.scm (ghc-extra): Update to 1.7.1.
>>
>> Thanks! Pushed as b431f6c9ccfa104811dc0697d6fec84bf8b08035
>
> I know I’m a few months late, but I think the update may have been
> incorrect, as it is not aligned with the rest of our Haskell packages.
> We should aim to keep all Haskell packages at the same LTS release.  As
> you can see here, version 1.7.1 does not correspond to any LTS release:
>
>     https://www.stackage.org/package/extra/snapshots

Hi Ricardo, this was fixed with commit
0cec5c4eb1b4ac9a3fbe3f11cffff92e01ff4c58.

Best wishes, hope you are well!

Brett Gilio
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index e368082c03..418eb7cc46 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -3774,7 +3774,7 @@  versions of GHC (i.e., < 6.10).")
 (define-public ghc-extra
   (package
     (name "ghc-extra")
-    (version "1.6.18")
+    (version "1.7.1")
     (source
      (origin
        (method url-fetch)
@@ -3784,12 +3784,13 @@  versions of GHC (i.e., < 6.10).")
              ".tar.gz"))
        (sha256
         (base32
-         "0jvd4l0hi8pf5899pxc32yc638y0mrc357w0rph99k3hm277i0cy"))))
+         "0zshxv9dnd8vksncmb8dj4wvq2wdybzwxyhmy2zp6a81icm4azx4"))))
     (build-system haskell-build-system)
     (inputs
      `(("ghc-clock" ,ghc-clock)
        ("ghc-semigroups" ,ghc-semigroups)
-       ("ghc-quickcheck" ,ghc-quickcheck)))
+       ("ghc-quickcheck" ,ghc-quickcheck)
+       ("ghc-quickcheck-instances" ,ghc-quickcheck-instances)))
     (home-page "https://github.com/ndmitchell/extra")
     (synopsis "Extra Haskell functions")
     (description "This library provides extra functions for the standard