diff mbox series

[bug#39943,v2,4/4] gnu: Add hyperledger-iroha.

Message ID 20200310083105.21013-5-efraim@flashner.co.il
State Accepted
Headers show
Series WIP: Hyperledger Iroha | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Efraim Flashner March 10, 2020, 8:31 a.m. UTC
From: Pierre Neidhardt <mail@ambrevar.xyz>

This package was co-authored with Efraim Flashner <efraim@flashner.co.il>

* gnu/packages/hyperledger.scm (hyperledger-iroha): New variable.
---
 gnu/packages/hyperledger.scm | 84 +++++++++++++++++++++++++++++++++++-
 1 file changed, 82 insertions(+), 2 deletions(-)

Comments

Pierre Neidhardt March 11, 2020, 2:13 p.m. UTC | #1
I've tested it and run the example here
https://iroha.readthedocs.io/en/latest/getting_started/cli-guide.html
It works!

Patch looks good, feel free to merge.
A few comments below:

> +              (snippet
> +               '(begin
> +                  ;; Backport unversioned fmt dependency:
> +                  (substitute* "libs/logger/logger.hpp"
> +                    (("fmt::v5") "fmt"))
> +                  #t))))

Mention the commit you've sent me and that this should be removed on
next update.

> +    (build-system cmake-build-system)
> +    (arguments
> +     `(#:configure-flags
> +       '("-DTESTING=OFF"
> +         ; Don't install the shared libraries of the dependencies:
> +         "-DENABLE_LIBS_PACKAGING=OFF")
> +       #:tests? #f

Explain why the tests must be disabled.

> +       #:test-target "."

Why setting the test-target if you are not running it?

> +       #:phases
> +       (modify-phases %standard-phases
> +         (add-after 'unpack 'change-compilation-flags
> +           (lambda _
> +             (substitute* "cmake/functions.cmake"
> +               (("-Werror") ""))
> +             #t)))))

Why do you need to do this?

> +    ;; See https://iroha.readthedocs.io/en/latest/build/index.html.
> +    (native-inputs
> +     `(("googletest" ,googletest)))
> +    (inputs
> +     `(("boost" ,boost-1.69)
> +       ("fmt" ,fmt)
> +       ("gflags" ,gflags)
> +       ("grpc" ,grpc)
> +       ("hyperledger-iroha-ed25519" ,hyperledger-iroha-ed25519)
> +       ("postgresql" ,postgresql)
> +       ("protobuf" ,protobuf)
> +       ("rapidjson" ,rapidjson)
> +       ("rxcpp" ,rxcpp)
> +       ("soci" ,soci)
> +       ("spdlog" ,spdlog)
> +       ("tbb" ,tbb)))
> +    (synopsis "Simple, decentralized ledger")
> +    (description "Iroha is a distributed ledger technology (DLT). Iroha has

Double spacing.

Thanks!
Cheers!
Efraim Flashner March 12, 2020, 1:40 p.m. UTC | #2
On Wed, Mar 11, 2020 at 03:13:25PM +0100, Pierre Neidhardt wrote:
> I've tested it and run the example here
> https://iroha.readthedocs.io/en/latest/getting_started/cli-guide.html
> It works!
> 
> Patch looks good, feel free to merge.
> A few comments below:
> 
> > +              (snippet
> > +               '(begin
> > +                  ;; Backport unversioned fmt dependency:
> > +                  (substitute* "libs/logger/logger.hpp"
> > +                    (("fmt::v5") "fmt"))
> > +                  #t))))
> 
> Mention the commit you've sent me and that this should be removed on
> next update.

Done

> 
> > +    (build-system cmake-build-system)
> > +    (arguments
> > +     `(#:configure-flags
> > +       '("-DTESTING=OFF"
> > +         ; Don't install the shared libraries of the dependencies:
> > +         "-DENABLE_LIBS_PACKAGING=OFF")
> > +       #:tests? #f
> 
> Explain why the tests must be disabled.
> 

Noted

> > +       #:test-target "."
> 
> Why setting the test-target if you are not running it?
> 

I added a note to the build instructions, for when we can run the tests

> > +       #:phases
> > +       (modify-phases %standard-phases
> > +         (add-after 'unpack 'change-compilation-flags
> > +           (lambda _
> > +             (substitute* "cmake/functions.cmake"
> > +               (("-Werror") ""))
> > +             #t)))))
> 
> Why do you need to do this?
> 

Turns out we don't, I removed it

> > +    ;; See https://iroha.readthedocs.io/en/latest/build/index.html.
> > +    (native-inputs
> > +     `(("googletest" ,googletest)))
> > +    (inputs
> > +     `(("boost" ,boost-1.69)
> > +       ("fmt" ,fmt)
> > +       ("gflags" ,gflags)
> > +       ("grpc" ,grpc)
> > +       ("hyperledger-iroha-ed25519" ,hyperledger-iroha-ed25519)
> > +       ("postgresql" ,postgresql)
> > +       ("protobuf" ,protobuf)
> > +       ("rapidjson" ,rapidjson)
> > +       ("rxcpp" ,rxcpp)
> > +       ("soci" ,soci)
> > +       ("spdlog" ,spdlog)
> > +       ("tbb" ,tbb)))
> > +    (synopsis "Simple, decentralized ledger")
> > +    (description "Iroha is a distributed ledger technology (DLT). Iroha has
> 
> Double spacing.
> 
> Thanks!
> Cheers!
> 
> -- 
> Pierre Neidhardt
> https://ambrevar.xyz/
Pierre Neidhardt March 12, 2020, 1:45 p.m. UTC | #3
Thanks a lot!
diff mbox series

Patch

diff --git a/gnu/packages/hyperledger.scm b/gnu/packages/hyperledger.scm
index 71194fba38..697074d9a9 100644
--- a/gnu/packages/hyperledger.scm
+++ b/gnu/packages/hyperledger.scm
@@ -1,6 +1,7 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2019, 2020 Pierre Neidhardt <mail@ambrevar.xyz>
 ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -19,18 +20,28 @@ 
 
 (define-module (gnu packages hyperledger)
   #:use-module (ice-9 match)
+  #:use-module (guix build-system cmake)
   #:use-module (guix build-system go)
-  #:use-module (guix build-system trivial)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module (guix licenses)
   #:use-module (gnu packages)
   #:use-module (gnu packages base)
+  #:use-module (gnu packages boost)
+  #:use-module (gnu packages check)
   #:use-module (gnu packages curl)
+  #:use-module (gnu packages databases)
   #:use-module (gnu packages docker)
   #:use-module (gnu packages golang)
-  #:use-module (gnu packages version-control))
+  #:use-module (gnu packages logging)
+  #:use-module (gnu packages machine-learning)
+  #:use-module (gnu packages popt)
+  #:use-module (gnu packages pretty-print)
+  #:use-module (gnu packages protobuf)
+  #:use-module (gnu packages tbb)
+  #:use-module (gnu packages version-control)
+  #:use-module (gnu packages web))
 
 (define-public hyperledger-fabric
   (package
@@ -136,3 +147,72 @@  This project offers at least two different C implementations for every
 module.  Every implementation can be replaced with another one at
 link-time.  New implementations can be added as well.")
     (license asl2.0)))
+
+(define-public hyperledger-iroha
+  (package
+    (name "hyperledger-iroha")
+    (version "1.1.1")
+    (home-page "https://github.com/hyperledger/iroha")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url home-page)
+                     (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "014mbwq059yxwihw0mq8zgns53fsw8ckczi1lw8q9pz3pk86pa9b"))
+              (modules '((guix build utils)))
+              (snippet
+               '(begin
+                  ;; Backport unversioned fmt dependency:
+                  (substitute* "libs/logger/logger.hpp"
+                    (("fmt::v5") "fmt"))
+                  #t))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:configure-flags
+       '("-DTESTING=OFF"
+         ; Don't install the shared libraries of the dependencies:
+         "-DENABLE_LIBS_PACKAGING=OFF")
+       #:tests? #f
+       #:test-target "."
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'change-compilation-flags
+           (lambda _
+             (substitute* "cmake/functions.cmake"
+               (("-Werror") ""))
+             #t)))))
+    ;; See https://iroha.readthedocs.io/en/latest/build/index.html.
+    (native-inputs
+     `(("googletest" ,googletest)))
+    (inputs
+     `(("boost" ,boost-1.69)
+       ("fmt" ,fmt)
+       ("gflags" ,gflags)
+       ("grpc" ,grpc)
+       ("hyperledger-iroha-ed25519" ,hyperledger-iroha-ed25519)
+       ("postgresql" ,postgresql)
+       ("protobuf" ,protobuf)
+       ("rapidjson" ,rapidjson)
+       ("rxcpp" ,rxcpp)
+       ("soci" ,soci)
+       ("spdlog" ,spdlog)
+       ("tbb" ,tbb)))
+    (synopsis "Simple, decentralized ledger")
+    (description "Iroha is a distributed ledger technology (DLT). Iroha has
+essential functionality for your asset, information and identity management
+needs, at the same time being a crash fault-tolerant tool.
+
+Iroha has the following features:
+
+@itemize
+@item Creation and management of custom fungible assets, such as currencies, kilos of gold, etc.
+@item Management of user accounts
+@item Taxonomy of accounts based on domains in the system
+@item The system of rights and verification of user permissions for the execution of transactions and queries in the system
+@item Validation of business rules for transactions and queries in the system
+@item Multisignature transactions
+@end itemize\n")
+    (license asl2.0)))