diff mbox series

[bug#39914] gnu: Add font-opendyslexic.

Message ID 20200304194406.11231-1-efraim@flashner.co.il
State Accepted
Headers show
Series [bug#39914] gnu: Add font-opendyslexic. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Efraim Flashner March 4, 2020, 7:44 p.m. UTC
* gnu/packages/fonts.scm (font-opendyslexic): New variable.
---
 gnu/packages/fonts.scm | 23 ++++++++++++++++++++++-
 1 file changed, 22 insertions(+), 1 deletion(-)

Comments

Arun Isaac March 8, 2020, 9:37 a.m. UTC | #1
Hi,

It seems like this font is already packaged for Guix. See package
font-open-dyslexic. Your new package is called font-opendyslexic, that
is, without the second hyphen.

Regards,
Arun.
Efraim Flashner March 8, 2020, 12:15 p.m. UTC | #2
On Sun, Mar 08, 2020 at 03:07:27PM +0530, Arun Isaac wrote:
> 
> Hi,
> 
> It seems like this font is already packaged for Guix. See package
> font-open-dyslexic. Your new package is called font-opendyslexic, that
> is, without the second hyphen.

This one is a re-implementation of the previous font, under a different
license. Do you think I should just replace the previous one?
Arun Isaac March 8, 2020, 1:23 p.m. UTC | #3
> This one is a re-implementation of the previous font, under a different
> license.

Oh, I see.

> Do you think I should just replace the previous one?

Yes, please replace the older package. Minor nitpick though: The new
package name font-opendyslexic without the second hyphen seems more in
line with the upstream name. So, perhaps you should deprecate the old
package in favor of this new one.
Efraim Flashner March 8, 2020, 8:44 p.m. UTC | #4
On Sun, Mar 08, 2020 at 06:53:26PM +0530, Arun Isaac wrote:
> 
> > This one is a re-implementation of the previous font, under a different
> > license.
> 
> Oh, I see.
> 
> > Do you think I should just replace the previous one?
> 
> Yes, please replace the older package. Minor nitpick though: The new
> package name font-opendyslexic without the second hyphen seems more in
> line with the upstream name. So, perhaps you should deprecate the old
> package in favor of this new one.

Sounds like a plan. Patch pushed.
diff mbox series

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 186e1eecff..ae78e7e0ab 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -11,7 +11,7 @@ 
 ;;; Copyright © 2016 Jookia <166291@gmail.com>
 ;;; Copyright © 2016 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2016 Dmitry Nikolaev <cameltheman@gmail.com>
-;;; Copyright © 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2016 Toni Reina <areina@riseup.net>
 ;;; Copyright © 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -1265,6 +1265,27 @@  emphasis while still being readable.")
 no copy of one or more of the Font Software typefaces may be sold by
 itself."))))
 
+(define-public font-opendyslexic
+  (package
+    (name "font-opendyslexic")
+    (version "0.91.12")
+    (source
+      (origin
+        (method url-fetch/zipbomb)
+        (uri (string-append "https://github.com/antijingoist/opendyslexic/"
+                            "releases/download/v" version
+                            "/opendyslexic-0.910.12-rc2-2019.10.17.zip"))
+        (sha256
+         (base32
+          "11ml7v4iyf3hr0fbnkwz8afb8vi58wbcfnmn4gyvrwh9jk5pybdr"))))
+    (build-system font-build-system)
+    (native-inputs `(("unzip" ,unzip)))
+    (home-page "https://opendyslexic.org/")
+    (synopsis "Typeface for Dyslexia")
+    (description "OpenDyslexic is a typeface designed against some common
+symptoms of dyslexia.")
+    (license license:silofl1.1)))
+
 (define-public font-dosis
   (package
     (name "font-dosis")