diff mbox series

[bug#39897] Remove package brotli

Message ID 20200304095654.GB17022@zpidnp36
State Accepted
Headers show
Series [bug#39897] Remove package brotli | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Lars-Dominik Braun March 4, 2020, 9:56 a.m. UTC
Hi,

this series removes the package brotli, which is parallel to google-brotli.
The latter provides version 1.0.7 of the shared libraries, whereas brotli
provided an earlier, unknown version. Its only dependent was woff2, which has
been upgraded to the proper release 1.0.2 and which in turn is only used by
font-fantasque-sanse. Both builds succeed.

Cheers,
Lars

Comments

Ludovic Courtès March 11, 2020, 5:36 p.m. UTC | #1
Hi,

Lars-Dominik Braun <ldb@leibniz-psychology.org> skribis:

> this series removes the package brotli, which is parallel to google-brotli.
> The latter provides version 1.0.7 of the shared libraries, whereas brotli
> provided an earlier, unknown version. Its only dependent was woff2, which has
> been upgraded to the proper release 1.0.2 and which in turn is only used by
> font-fantasque-sanse. Both builds succeed.

I pushed these two patches a few days ago but forgot to reply (?).

I made “brotli” a deprecated alias for “google-brotli”.

Thanks!

Ludo’.
diff mbox series

Patch

From d1497d1da6817da78846601b90aa1b3fcfe36cbc Mon Sep 17 00:00:00 2001
From: Lars-Dominik Braun <ldb@leibniz-psychology.org>
Date: Wed, 4 Mar 2020 10:48:45 +0100
Subject: [PATCH 2/2] gnu: brotli: Remove package

Same package is provided by google-brotli.

* gnu/packages/compression.scm (brotli): Remove unused variable
---
 gnu/packages/compression.scm | 43 ------------------------------------
 1 file changed, 43 deletions(-)

diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index ee10bd03ce..bfce15558b 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -883,49 +883,6 @@  possible and can compress in parallel.  This is especially useful for large
 tarballs.")
     (license license:bsd-2)))
 
-(define-public brotli
-  (let ((commit "e992cce7a174d6e2b3486616499d26bb0bad6448")
-        (revision "1"))
-    (package
-      (name "brotli")
-      (version (string-append "0.1-" revision "."
-                              (string-take commit 7)))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://github.com/bagder/libbrotli.git")
-                      (commit commit)
-                      (recursive? #t)))
-                (file-name (string-append name "-" version ".tar.xz"))
-                (sha256
-                 (base32
-                  "1qxxsasvwbbbh6dl3138y9h3fg0q2v7xdk5jjc690bdg7g1wrj6n"))
-                (modules '((guix build utils)))
-                (snippet '(begin
-                            ;; This is a recursive submodule that is
-                            ;; unnecessary for this package, so delete it.
-                            (delete-file-recursively "brotli/terryfy")
-                            #t))))
-      (build-system gnu-build-system)
-      (native-inputs
-       `(("autoconf" ,autoconf)
-         ("automake" ,automake)
-         ("libtool" ,libtool)))
-      (arguments
-       `(#:phases (modify-phases %standard-phases
-                    (add-after 'unpack 'autogen
-                      (lambda _
-                        (mkdir "m4")
-                        (invoke "autoreconf" "-vfi"))))))
-      (home-page "https://github.com/bagder/libbrotli/")
-      (synopsis "Implementation of the Brotli compression algorithm")
-      (description
-       "Brotli is a general-purpose lossless compression algorithm.  It is
-similar in speed to deflate but offers denser compression.  This package
-provides encoder and a decoder libraries: libbrotlienc and libbrotlidec,
-respectively, based on the reference implementation from Google.")
-      (license license:expat))))
-
 (define-public bsdiff
   (package
     (name "bsdiff")
-- 
2.20.1