diff mbox series

[bug#39882,1/1] gnu: Add kexec-tools.

Message ID 20200303115937.89609-1-cmmarusich@gmail.com
State Accepted
Headers show
Series Add kexec-tools. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Christopher Marusich March 3, 2020, 11:59 a.m. UTC
* gnu/packages/linux.scm (kexec-tools): New variable.
---
 gnu/packages/linux.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 0289047d27..fa9fdf759c 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -40,6 +40,7 @@ 
 ;;; Copyright © 2019 Kei Kebreau <kkebreau@posteo.net>
 ;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
 ;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2020 Chris Marusich <cmmarusich@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -6408,3 +6409,27 @@  user space tracer.  It receives commands from a session daemon, for example to
 enable and disable specific instrumentation points, and writes event records
 to ring buffers shared with a consumer daemon.")
     (license license:lgpl2.1+)))
+
+(define-public kexec-tools
+  (package
+    (name "kexec-tools")
+    (version "2.0.20")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://mirrors.edge.kernel.org/pub/linux"
+                                  "/utils/kernel/kexec/kexec-tools-" version
+                                  ".tar.xz"))
+              (sha256
+               (base32
+                "1j7qlhxk1rbv9jbj8wd6hb7zl8p2mp29ymrmccgmsi0m0dzhgn6s"))))
+    (build-system gnu-build-system)
+    (arguments
+     ;; There are no automated tests.
+     '(#:tests? #f))
+    (home-page "https://mirrors.edge.kernel.org/pub/linux/utils/kernel/kexec/")
+    (synopsis "@code{kexec} and related tools for Linux kernels")
+    (description "This package provides the @code{kexec} program and ancillary
+utilities.  Using @code{kexec}, it is possible to boot directly into a new
+Linux kernel from the context of an already-running Linux kernel, bypassing
+the normal system boot process.")
+    (license license:gpl2)))