diff mbox series

[bug#39880] gnu: python-keras: Fix tests.

Message ID 20200303092201.7174-1-mail@ambrevar.xyz
State Accepted
Headers show
Series [bug#39880] gnu: python-keras: Fix tests. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Pierre Neidhardt March 3, 2020, 9:22 a.m. UTC
* gnu/packages/machine-learning.scm (python-keras)[origin]: Add patch to
  remove unstable selu test.
* gnu/local.mk: Include patch.
---
 gnu/local.mk                      | 1 +
 gnu/packages/machine-learning.scm | 4 +++-
 2 files changed, 4 insertions(+), 1 deletion(-)

Comments

Efraim Flashner March 3, 2020, 10:17 a.m. UTC | #1
You forgot to add the patch :P
Pierre Neidhardt March 3, 2020, 10:38 a.m. UTC | #2
Oops!  Resent.
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 857345cfad..e5922aae54 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1329,6 +1329,7 @@  dist_patch_DATA =						\
   %D%/packages/patches/python-configobj-setuptools.patch	\
   %D%/packages/patches/python-faker-fix-build-32bit.patch	\
   %D%/packages/patches/python-keras-integration-test.patch	\
+  %D%/packages/patches/python-keras-selu-test.patch		\
   %D%/packages/patches/python-pep8-stdlib-tokenize-compat.patch \
   %D%/packages/patches/python-pyfakefs-remove-bad-test.patch	\
   %D%/packages/patches/python-flint-includes.patch		\
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 8262a418cc..7fbdef0163 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -1863,7 +1863,9 @@  with image data, text data, and sequence data.")
      (origin
        (method url-fetch)
        (uri (pypi-uri "Keras" version))
-       (patches (search-patches "python-keras-integration-test.patch"))
+       (patches
+        (search-patches "python-keras-selu-test.patch" ; Numerically unstable?
+                        "python-keras-integration-test.patch"))
        (sha256
         (base32
          "1j8bsqzh49vjdxy6l1k4iwax5vpjzniynyd041xjavdzvfii1dlh"))))