diff mbox series

[bug#39798,09/13] gnu: Add ghc-base-compat-0.11.

Message ID 20200226114605.15106-9-mail@ambrevar.xyz
State Accepted
Headers show
Series [bug#39798,01/13] gnu: ghc-hsyaml: Update to 0.2.1.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Pierre Neidhardt Feb. 26, 2020, 11:46 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-base-compat-0.11): New variable.
---
 gnu/packages/haskell-xyz.scm | 15 +++++++++++++++
 1 file changed, 15 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index b0ea9192e3..9e85f89248 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -767,6 +767,21 @@  of base to a wider range of compilers, without requiring the use of CPP
 pragmas in your code.")
     (license license:bsd-3)))
 
+(define-public ghc-base-compat-0.11
+  (package
+    (inherit ghc-base-compat)
+    (version "0.11.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/base-compat/base-compat-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "0dkdmyxg8hfjn1zyrp4mahkr90g4y672mlvkj0m1krwkxi11avrm"))))))
+
 (define-public ghc-base-compat-batteries
   (package
     (name "ghc-base-compat-batteries")