diff mbox series

[bug#39783] gnu: gsettings-desktop-schemas: patch monospace font.

Message ID 20200225145910.26066-1-leo.prikler@student.tugraz.at
State Accepted
Headers show
Series [bug#39783] gnu: gsettings-desktop-schemas: patch monospace font. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Leo Prikler Feb. 25, 2020, 2:59 p.m. UTC
* gnu/packages/gnome.scm (gsettings-desktop-schemas)[arguments]<phases>:
Rename `set-adwaita-theme-file-name' to the more generic `patch-schemas'.
Add patch for the monospace font (Source Code Pro 10 -> Monospace 11).
Adjust comments.
---
 gnu/packages/gnome.scm | 10 ++++++----
 1 file changed, 6 insertions(+), 4 deletions(-)

Comments

Leo Prikler March 15, 2020, 1:41 p.m. UTC | #1
It appears this has fallen under the radar.
To perhaps clarify the intent of this patch, it fixes the bug, where
GNOME Terminal and other stuff that relies on the Monospace font being
defined appears quite ugly with the default settings.

Regards,
Leo
Marius Bakke March 20, 2020, 6:02 p.m. UTC | #2
Leo Prikler <leo.prikler@student.tugraz.at> writes:

> * gnu/packages/gnome.scm (gsettings-desktop-schemas)[arguments]<phases>:
> Rename `set-adwaita-theme-file-name' to the more generic `patch-schemas'.
> Add patch for the monospace font (Source Code Pro 10 -> Monospace 11).
> Adjust comments.

Thanks for finding the root cause of the broken default gnome-terminal
font.  Since there has been no feedback in a couple of weeks, I went
ahead and applied it.

I also updated your copyright header.  Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index af45ceb505..e066b4c93c 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -1575,15 +1575,17 @@  on the GNOME Desktop with a single simple application.")
     (build-system meson-build-system)
     (arguments
      '(#:phases (modify-phases %standard-phases
-                  (add-after 'unpack 'set-adwaita-theme-file-name
+                  (add-after 'unpack 'patch-schemas
                     (lambda* (#:key inputs #:allow-other-keys)
-                      ;; Provide the correct file name of the default GNOME
-                      ;; background, 'adwaita-timed.xml'.
                       (let ((theme (assoc-ref inputs "gnome-backgrounds")))
                         (substitute* (find-files "schemas"
                                                  "\\.gschema\\.xml\\.in$")
+                          ;; Provide the correct file name of the default GNOME
+                          ;; background, 'adwaita-timed.xml'.
                           (("@datadir@/backgrounds/gnome")
-                           (string-append theme "/share/backgrounds/gnome")))
+                           (string-append theme "/share/backgrounds/gnome"))
+                          ;; Do not reference fonts, that may not exist.
+                          (("'Source Code Pro 10'") "'Monospace 11'"))
                         #t))))))
     (inputs
      `(("glib" ,glib)