diff mbox series

[bug#39599,v2] gnu: Add gnome-shell-extension-paperwm.

Message ID 20200221033733.11242-2-jackhill@jackhill.us
State Accepted
Headers show
Series [bug#39599,v2] gnu: Add gnome-shell-extension-paperwm. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Jack Hill Feb. 21, 2020, 3:37 a.m. UTC
* gnu/packages/gnome-xyz.scm (gnome-shell-extension-paperwm): New variable.

Co-authored-by: Alex Griffin <a@ajgrf.com>
---
 gnu/packages/gnome-xyz.scm | 39 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)

Comments

Alex Griffin Feb. 21, 2020, 2:34 p.m. UTC | #1
Jack,

Thank you, I just committed your improvements with some slight modifications!

I had noticed the issue and intended to fix it myself, but after stepping away from my computer for a while, I must have forgotten about it and sent my patch too early.
Jack Hill Feb. 21, 2020, 4:22 p.m. UTC | #2
Alex,

On Fri, 21 Feb 2020, Alex Griffin wrote:

> Thank you, I just committed your improvements with some slight 
> modifications!

Thanks for the improvements. However, I don't think this change was 
warranted:

-          #:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$" "\\.png$"
-                            "\\.xml$" "\\.compiled$")))))
+          #:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$" "\\.png$" "\\.xml$")))

I think we still want to install the gschemas.compiled file that build in 
the new compile-schemas phase.

> I had noticed the issue and intended to fix it myself, but after 
> stepping away from my computer for a while, I must have forgotten about 
> it and sent my patch too early.

No worries, I'm happy to serve as a second set of eyes.

Best,
Jack
Alex Griffin Feb. 21, 2020, 6:48 p.m. UTC | #3
On Fri, Feb 21, 2020, at 4:22 PM, Jack Hill wrote:
> Thanks for the improvements. However, I don't think this change was 
> warranted:
> 
> -          #:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$" "\\.png$"
> -                            "\\.xml$" "\\.compiled$")))))
> +          #:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$" "\\.png$" 
> "\\.xml$")))
> 
> I think we still want to install the gschemas.compiled file that build in 
> the new compile-schemas phase.

You're right of course. I just committed the fix.
Jack Hill Feb. 21, 2020, 6:51 p.m. UTC | #4
On Fri, 21 Feb 2020, Alex Griffin wrote:

> On Fri, Feb 21, 2020, at 4:22 PM, Jack Hill wrote:
>> Thanks for the improvements. However, I don't think this change was
>> warranted:
>>
>> -          #:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$" "\\.png$"
>> -                            "\\.xml$" "\\.compiled$")))))
>> +          #:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$" "\\.png$"
>> "\\.xml$")))
>>
>> I think we still want to install the gschemas.compiled file that build in
>> the new compile-schemas phase.
>
> You're right of course. I just committed the fix.

Awesome, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/gnome-xyz.scm b/gnu/packages/gnome-xyz.scm
index 7f375fefc5..59913e0602 100644
--- a/gnu/packages/gnome-xyz.scm
+++ b/gnu/packages/gnome-xyz.scm
@@ -2,6 +2,8 @@ 
 ;;; Copyright © 2019 Leo Prikler <leo.prikler@student.tugraz.at>
 ;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
 ;;; Copyright © 2019 Giacomo Leidi <goodoldpaul@autistici.org>
+;;; Copyright © 2020 Alex Griffin <a@ajgrf.com>
+;;; Copyright © 2020 Jack Hill <jackhill@jackhill.us>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -21,6 +23,7 @@ 
 (define-module (gnu packages gnome-xyz)
   #:use-module (guix build-system trivial)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system copy)
   #:use-module (guix git-download)
   #:use-module (guix packages)
   #:use-module ((guix licenses) #:prefix license:)
@@ -304,6 +307,42 @@  It uses ES6 syntax and claims to be more actively maintained than others.")
     (home-page "https://extensions.gnome.org/extension/2182/noannoyance/")
     (license license:gpl2)))
 
+(define-public gnome-shell-extension-paperwm
+  (package
+    (name "gnome-shell-extension-paperwm")
+    (version "34.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/paperwm/PaperWM.git")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1qry75f696pgmd9yzqvwhq5h6cipin2fvk7h881g29cjcpxim37a"))
+              (snippet
+               '(begin (delete-file "schemas/gschemas.compiled")))))
+    (build-system copy-build-system)
+    (arguments
+     '(#:install-plan
+       '(("." "share/gnome-shell/extensions/paperwm@hedning:matrix.org"
+          #:include-regexp ("\\.js(on)?$" "\\.css$" "\\.ui$" "\\.png$"
+                            "\\.xml$" "\\.compiled$")))
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'install 'compile-schemas
+           (lambda _
+             (with-directory-excursion "schemas"
+               (invoke "make")))))))
+    (native-inputs
+     `(("glib:bin" ,glib "bin"))) ; for glib-compile-schemas
+    (home-page "https://github.com/paperwm/PaperWM")
+    (synopsis "Tiled scrollable window management for GNOME Shell")
+    (description "PaperWM is an experimental GNOME Shell extension providing
+scrollable tiling of windows and per monitor workspaces.  It's inspired by paper
+notebooks and tiling window managers.")
+    (license license:gpl3)))
+
 (define-public numix-theme
   (package
     (name "numix-theme")