diff mbox series

[bug#39694,SHEPHERD] build: Adjust clean targets.

Message ID 20200220154221.22104-1-efraim@flashner.co.il
State Accepted
Headers show
Series [bug#39694,SHEPHERD] build: Adjust clean targets. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Efraim Flashner Feb. 20, 2020, 3:42 p.m. UTC
Makefile.am: Add man pages to the 'make clean' target.
---
Currently 'man shepherd' shows version 0.6.1, 'man herd' 0.6.0, 'man
halt' and 'man reboot' 0.3.2. With this patch these 4 manpages are added
to the 'make clean' list and are deleted. The manpage creation works as
expected.

---
 Makefile.am | 3 +++
 1 file changed, 3 insertions(+)

Comments

Ludovic Courtès March 6, 2020, 11:10 a.m. UTC | #1
Hi Efraim,

Efraim Flashner <efraim@flashner.co.il> skribis:

> Makefile.am: Add man pages to the 'make clean' target.
> ---
> Currently 'man shepherd' shows version 0.6.1, 'man herd' 0.6.0, 'man
> halt' and 'man reboot' 0.3.2. With this patch these 4 manpages are added
> to the 'make clean' list and are deleted. The manpage creation works as
> expected.

[...]

> +CLEANFILES += $(dist_man1_MANS) $(dist_man8_MANS)

This would remove man pages upon “make clean”, whereas they should only
be removed upon “make distclean”, per GNU conventions.

I went with a different fix in Shepherd commit
f32a2ff8ad329f224b2f693ad7e9fefac142a459.

Thank you!

Ludo’.
diff mbox series

Patch

diff --git a/Makefile.am b/Makefile.am
index 9a1f019..8cf98d6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,6 +2,7 @@ 
 # Copyright © 2002, 2003 Wolfgang Jährling <wolfgang@pro-linux.de>
 # Copyright © 2013, 2014, 2015, 2016, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
 # Copyright © 2018 Carlo Zancanaro <carlo@zancanaro.id.au>
+# Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
 #
 # This file is part of the GNU Shepherd.
 #
@@ -122,6 +123,8 @@  doc/%.8: modules/shepherd/scripts/%.scm
 dist_man1_MANS = doc/shepherd.1 doc/herd.1
 dist_man8_MANS = doc/halt.8 doc/reboot.8
 
+CLEANFILES += $(dist_man1_MANS) $(dist_man8_MANS)
+
 # Things not automatically included in the distribution.
 EXTRA_DIST +=					\
   build-aux/config.rpath			\