diff mbox series

[bug#39599,3/4] gnu: Add clojure-wrapper.

Message ID 20200217111228.23716-3-mail@ambrevar.xyz
State Accepted
Headers show
Series New build system: copy-build-system | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Pierre Neidhardt Feb. 17, 2020, 11:12 a.m. UTC
* gnu/packages/clojure.scm (clojure-wrapper): New variable.
---
 gnu/packages/clojure.scm | 30 +++++++++++++++++++++++++++++-
 1 file changed, 29 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/clojure.scm b/gnu/packages/clojure.scm
index 9a1ceed66c..f34e4dadab 100644
--- a/gnu/packages/clojure.scm
+++ b/gnu/packages/clojure.scm
@@ -1,8 +1,9 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
-;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2018, 2020 Pierre Neidhardt <mail@ambrevar.xyz>
 ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2020 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2020 Jesse Gibbons <jgibbons2357@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -27,6 +28,7 @@ 
   #:use-module (guix git-download)
   #:use-module (guix build-system ant)
   #:use-module (guix build-system clojure)
+  #:use-module (guix build-system copy)
   #:use-module (ice-9 match))
 
 (define-public clojure
@@ -321,3 +323,29 @@  tree.
      "The @code{tools.cli} library provides Clojure programmers with tools to
 work with command-line arguments.")
     (license license:epl1.0)))
+
+(define-public clojure-wrapper
+  (package
+    (name "clojure-wrapper")
+    (version "1.10.1.507")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/clojure/brew-install.git")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1zipz22pszv4vls4qhxkia8gm86s1wkahr0jdbqhc46mpd8n54fz"))))
+    (build-system copy-build-system)
+    (arguments
+     `(#:install-plan
+       `(("src/main/resources/" "bin/" #:include ("clj" "clojure"))
+         ("doc/clojure.1" "share/man/man1/")
+         ("epl.html" ,,(string-append "share/doc/clojure-" (package-version clojure) "/")))))
+    (synopsis "Clojure launch scripts")
+    (description "Scripts to launch Clojure from the command line.
+Without these scripts a user would need to run jar with the Clojure jar's
+location.")
+    (home-page "https://clojure.org/")
+    (license license:epl1.0)))