diff mbox series

[bug#39604] gnu: Add python-fuzzywuzzy.

Message ID 20200214185323.6778-1-sirgazil@zoho.com
State Accepted
Headers show
Series [bug#39604] gnu: Add python-fuzzywuzzy. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

ashish.is--- via Guix-patches" via Feb. 14, 2020, 6:53 p.m. UTC
* gnu/packages/python-xyz.scm (python-fuzzywuzzy, python2-fuzzywuzzy):
  New variables.
---
 gnu/packages/python-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

Comments

Maja Kądziołka Feb. 14, 2020, 10:41 p.m. UTC | #1
On Fri, Feb 14, 2020 at 01:53:23PM -0500, sirgazil wrote:
> * gnu/packages/python-xyz.scm (python-fuzzywuzzy, python2-fuzzywuzzy):
>   New variables.
> ---
>  gnu/packages/python-xyz.scm | 29 +++++++++++++++++++++++++++++
>  1 file changed, 29 insertions(+)
> 
> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index ca559ca00a..aeea4df12a 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -69,6 +69,7 @@
>  ;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
>  ;;; Copyright © 2019 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
>  ;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
> +;;; Copyright © 2020 sirgazil <sirgazil@zoho.com>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -17541,3 +17542,31 @@ extensive support of PNG features.  It can also read and write Netpbm PAM
>  files, with a focus on its use as an intermediate format for implementing
>  custom PNG processing.")
>      (license license:expat)))
> +
> +(define-public python-fuzzywuzzy
> +  (package
> +    (name "python-fuzzywuzzy")
> +    (version "0.18.0")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (pypi-uri "fuzzywuzzy" version))
> +       (sha256
> +        (base32
> +         "1s00zn75y2dkxgnbw8kl8dw4p1mc77cv78fwfa4yb0274s96w0a5"))))
> +    (build-system python-build-system)
> +    (native-inputs
> +     `(("python-hypothesis" ,python-hypothesis)
> +       ("python-pycodestyle" ,python-pycodestyle)
> +       ("python-pytest" ,python-pytest)))
> +    (propagated-inputs
> +     `(("python-levenshtein" ,python-levenshtein)))
> +    (home-page "https://github.com/seatgeek/fuzzywuzzy")
> +    (synopsis "Fuzzy string matching in python")
This should be "Python" with a capital P. Apart from that, LGTM - pushed
as da8ca4c3fc2ac36977e3190bb05802c487619e8c.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ca559ca00a..aeea4df12a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -69,6 +69,7 @@ 
 ;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
 ;;; Copyright © 2019 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
 ;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
+;;; Copyright © 2020 sirgazil <sirgazil@zoho.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -17541,3 +17542,31 @@  extensive support of PNG features.  It can also read and write Netpbm PAM
 files, with a focus on its use as an intermediate format for implementing
 custom PNG processing.")
     (license license:expat)))
+
+(define-public python-fuzzywuzzy
+  (package
+    (name "python-fuzzywuzzy")
+    (version "0.18.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "fuzzywuzzy" version))
+       (sha256
+        (base32
+         "1s00zn75y2dkxgnbw8kl8dw4p1mc77cv78fwfa4yb0274s96w0a5"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-hypothesis" ,python-hypothesis)
+       ("python-pycodestyle" ,python-pycodestyle)
+       ("python-pytest" ,python-pytest)))
+    (propagated-inputs
+     `(("python-levenshtein" ,python-levenshtein)))
+    (home-page "https://github.com/seatgeek/fuzzywuzzy")
+    (synopsis "Fuzzy string matching in python")
+    (description "Approximate string matching using
+@emph{Levenshtein Distance} to calculate the differences between
+sequences.")
+    (license license:gpl2)))
+
+(define-public python2-fuzzywuzzy
+  (package-with-python2 python-fuzzywuzzy))