diff mbox series

[bug#39331,v3] gnu: Add emacs-persist.

Message ID 20200214165918.9452-1-robertsmith@posteo.net
State Accepted
Headers show
Series [bug#39331,v3] gnu: Add emacs-persist. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Robert Smith Feb. 14, 2020, 4:59 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-persist): New variable.
---
 gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

Nicolas Goaziou Feb. 17, 2020, 9:18 a.m. UTC | #1
Hello,

Robert Smith <robertsmith@posteo.net> writes:

> * gnu/packages/emacs-xyz.scm (emacs-persist): New variable.

Applied. Thank you!

I'm not closing this bug report in case you want to add Org Drill at
some point. Otherwise, you can also close it, and open a new bug report
for Org Drill.

Regards,
Robert Smith March 7, 2020, 11:50 p.m. UTC | #2
On Mon Feb 17, 2020 at 10:18 AM Nicolas Goaziou wrote:
> I'm not closing this bug report in case you want to add Org Drill at
> some point. Otherwise, you can also close it, and open a new bug report
> for Org Drill.

Still no word from upstream, so I'm closing the bug report.
Hopefully I'll open a new one for org-drill soon.

-Robert
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9087a8d98c..1cbcf8a91b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -58,6 +58,7 @@ 
 ;;; Copyright © 2019 Leo Prikler <leo.prikler@student.tugraz.at>
 ;;; Copyright © 2019 David Wilson <david@daviwil.com>
 ;;; Copyright © 2020 Paul Garlick <pgarlick@tourbillion-technology.com>
+;;; Copyright © 2020 Robert Smith <robertsmith@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -21455,3 +21456,24 @@  Flyspell's on-the-fly spell checking and extends these checks to also detect
 language.  Auto-dictionary then sets @code{ispell-dictionary} to use the
 detected language.")
     (license license:gpl2+)))
+
+(define-public emacs-persist
+  (package
+    (name "emacs-persist")
+    (version "0.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://elpa.gnu.org/packages/persist-"
+                           version ".tar"))
+       (sha256
+        (base32 "0gpxy41qawzss2526j9a7lys60vqma1lvamn4bfabwza7gfhac0q"))))
+    (build-system emacs-build-system)
+    (home-page "http://elpa.gnu.org/packages/persist.html")
+    (synopsis "Persist variables between emacs sessions")
+    (description
+     "This package provides variables which persist across sessions.
+Values are stored in a directory in @code{user-emacs-directory}, using
+one file per value.  This makes it easy to delete or remove unused
+variables.")
+    (license license:gpl3+)))