diff mbox series

[bug#39579,1/3] gnu: osinfo-db-tools: Add osinfo-db-tools.

Message ID 20200212163711.17468-1-brice@waegenei.re
State Accepted
Headers show
Series Include operating systems list in virt-manager. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Brice Waegeneire Feb. 12, 2020, 4:37 p.m. UTC
* gnu/packages/virtualization.scm (osinfo-db-tools): New variable.
---
 gnu/packages/virtualization.scm | 40 +++++++++++++++++++++++++++++++++
 1 file changed, 40 insertions(+)

Comments

Maja Kądziołka Feb. 16, 2020, 7:10 p.m. UTC | #1
On Wed, Feb 12, 2020 at 05:37:09PM +0100, Brice Waegeneire wrote:
> +(define-public osinfo-db-tools
> +  (package
> +    (name "osinfo-db-tools")
> +    (version "1.7.0")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (string-append "https://releases.pagure.org/libosinfo/osinfo-db-tools-"
> +                                  version ".tar.xz"))
> +
> +              (sha256
> +               (base32
> +                "08x8mrafphyll0d35xdc143rip3ahrz6bmzhc85nwhq7yk2vxpab"))))
> +    (build-system meson-build-system)
> +    (arguments
> +     `(#:configure-flags
> +       (list (string-append "--prefix=" (assoc-ref %outputs "out")))))
If I'm reading the source correctly, this argument isn't even used by
meson-build-system. Why is this necessary?

> +    (inputs
> +     `(("libsoup" ,libsoup)
> +       ("libxml2" ,libxml2)
> +       ("libxslt" ,libxslt)
> +       ("json-glib" ,json-glib)
> +       ("libarchive" ,libarchive)
> +       ("gobject-introspection" ,gobject-introspection)))
guix lint suggests that g-i should be a native-input

> +    (native-inputs
> +     `(("perl" ,perl)
> +       ("gettext" ,gettext-minimal)
> +       ("pkg-config" ,pkg-config)
> +       ;; Tests
> +       ("python" ,python)
> +       ("pytest" ,python-pytest)
> +       ("requests" ,python-requests)
> +       ))
You cruel madman, these parenthesis must be feeling quite lonely ;)

> +    (home-page "https://gitlab.com/libosinfo/osinfo-db-tools")
> +    (synopsis "Tools for managing the osinfo database")
> +    (description "This package contains a set of tools to assist administrators and
> +developers in managing the database.")
Please break lines at 80 characters when not inconvenient.

> +    (license license:lgpl2.0+)))
> -- 
> 2.25.0
Maja Kądziołka Feb. 16, 2020, 7:56 p.m. UTC | #2
On Sun, Feb 16, 2020 at 08:10:18PM +0100, Jakub Kądziołka wrote:
> On Wed, Feb 12, 2020 at 05:37:09PM +0100, Brice Waegeneire wrote:
> > +(define-public osinfo-db-tools
> > +  (package
> > +    (name "osinfo-db-tools")
> > +    (version "1.7.0")
> > +    (source (origin
> > +              (method url-fetch)
> > +              (uri (string-append "https://releases.pagure.org/libosinfo/osinfo-db-tools-"
> > +                                  version ".tar.xz"))
> > +
> > +              (sha256
> > +               (base32
> > +                "08x8mrafphyll0d35xdc143rip3ahrz6bmzhc85nwhq7yk2vxpab"))))
> > +    (build-system meson-build-system)
> > +    (arguments
> > +     `(#:configure-flags
> > +       (list (string-append "--prefix=" (assoc-ref %outputs "out")))))
> If I'm reading the source correctly, this argument isn't even used by
> meson-build-system. Why is this necessary?
Okay, I wasn't reading the source correctly, Vim's
search-at-word-boundaries hid the point where the variable is being
used. Still, the prefix option is already being set by
meson-build-system itself. I'm confused as to what this argument
is supposed to do.
diff mbox series

Patch

diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 3670b396a5..57d433599a 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -11,6 +11,7 @@ 
 ;;; Copyright © 2018 Sou Bunnbu <iyzsong@member.fsf.org>
 ;;; Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
 ;;; Copyright © 2019 Guy Fleury Iteriteka <hoonandon@gmail.com>
+;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -33,6 +34,7 @@ 
   #:use-module (gnu packages assembly)
   #:use-module (gnu packages attr)
   #:use-module (gnu packages autotools)
+  #:use-module (gnu packages backup)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages check)
   #:use-module (gnu packages cmake)
@@ -1382,3 +1384,41 @@  which is a hypervisor.")
     ;; TODO: Some files are licensed differently.  List those.
     (license license:gpl2)
     (supported-systems '("i686-linux" "x86_64-linux" "armhf-linux"))))
+
+(define-public osinfo-db-tools
+  (package
+    (name "osinfo-db-tools")
+    (version "1.7.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://releases.pagure.org/libosinfo/osinfo-db-tools-"
+                                  version ".tar.xz"))
+
+              (sha256
+               (base32
+                "08x8mrafphyll0d35xdc143rip3ahrz6bmzhc85nwhq7yk2vxpab"))))
+    (build-system meson-build-system)
+    (arguments
+     `(#:configure-flags
+       (list (string-append "--prefix=" (assoc-ref %outputs "out")))))
+    (inputs
+     `(("libsoup" ,libsoup)
+       ("libxml2" ,libxml2)
+       ("libxslt" ,libxslt)
+       ("json-glib" ,json-glib)
+       ("libarchive" ,libarchive)
+       ("gobject-introspection" ,gobject-introspection)))
+    (native-inputs
+     `(("perl" ,perl)
+       ("gettext" ,gettext-minimal)
+       ("pkg-config" ,pkg-config)
+       ;; Tests
+       ("python" ,python)
+       ("pytest" ,python-pytest)
+       ("requests" ,python-requests)
+       ))
+    (home-page "https://gitlab.com/libosinfo/osinfo-db-tools")
+    (synopsis "Tools for managing the osinfo database")
+    (description "This package contains a set of tools to assist administrators and
+developers in managing the database.")
+    (license license:lgpl2.0+)))