diff mbox series

[bug#39576] qdbm: fix segfault during test

Message ID 20200212.161457.1945473684782544947.post@thomasdanckaert.be
State Accepted
Headers show
Series [bug#39576] qdbm: fix segfault during test | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

Thomas Danckaert Feb. 12, 2020, 3:14 p.m. UTC
Hi Guix,

at some point, the package qdbm started running into a segfault 
during the test suite.   This small patch fixes that.

If it's ok, I can push the commit myself (I believe I still have 
commit rights), but since I haven't contributed in 2 years, I wanted 
to check if the patch meets all the requirements...

best,

Thomas

Comments

ashish.is--- via Guix-patches" via Feb. 12, 2020, 5:52 p.m. UTC | #1
Thomas,

Thomas Danckaert 写道:
> at some point, the package qdbm started running into a segfault 
> during the test suite.   This small patch fixes that.
>
> If it's ok, I can push the commit myself (I believe I still have 
> commit rights), but since I haven't contributed in 2 years, I 
> wanted 
> to check if the patch meets all the requirements...

Glad to hear you're still a Guixer.

You're listed as ‘inactive’[0], but TBH I don't know what that 
means.  If you're unable to push and/or interested in reactivating 
your account, let us know.

> -     `( #:configure-flags (list (string-append 
> "LDFLAGS=-Wl,-rpath="
> -                                               (assoc-ref 
> %outputs "out")
> -                                               "/lib"))))
> +     `(#:configure-flags (list (string-append 
> "LDFLAGS=-Wl,-rpath="
> +                                              (assoc-ref 
> %outputs "out")
> +                                              "/lib"))

I'd add a short ‘Fix a segmentation fault in the test suite’ 
comment here.

> +       #:make-flags '("CFLAGS=-fPIC")))

Sticking to one idiom (list …) is slightly newbie-friendlier, but 
LGTM either way.

Thanks!

T G-R

[0]: https://savannah.gnu.org/project/memberlist.php?group=guix
Thomas Danckaert Feb. 22, 2020, 4:49 p.m. UTC | #2
Hi Tobias,

I haven't contributed in a while (a job change made it harder), but 
I'm still an enthusiastic user.

Sorry for the late reply!  It seems like your answer didn't get 
forwarded to my mailbox (either that, or I accidentally removed it... 
I feel both are equally likely), so I only noticed when browsing the 
guix-patches web interface some time later.

I followed your suggestion about (list ...) and pushed the patch 
(after some gpg key expiry date song and dance...).

Thomas
diff mbox series

Patch

From bd557d5f63197712bbe5cde8f4a80e152b7ec586 Mon Sep 17 00:00:00 2001
From: Thomas Danckaert <thomas.danckaert@gmail.com>
Date: Wed, 12 Feb 2020 15:31:49 +0100
Subject: [PATCH] gnu: qdbm: Fix segfault during tests.

gnu/packages/databses.scm (qdbm): Add "CFLAGS=-fPIC" to make-flags.
---
 gnu/packages/databases.scm | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)

diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 587d993918..1cec7743b2 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -19,7 +19,7 @@ 
 ;;; Copyright © 2016 Danny Milosavljevic <dannym+a@scratchpost.org>
 ;;; Copyright © 2016, 2017, 2018, 2019 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2017, 2018 Julien Lepiller <julien@lepiller.eu>
-;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
+;;; Copyright © 2017, 2020 Thomas Danckaert <post@thomasdanckaert.be>
 ;;; Copyright © 2017 Jelle Licht <jlicht@fsfe.org>
 ;;; Copyright © 2017 Adriano Peluso <catonano@gmail.com>
 ;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
@@ -1060,9 +1060,10 @@  Most public APIs are compatible with @command{mysqlclient} and MySQLdb.")
          "0gmpvhn02pkq280ffmn4da1g4mdr1xxz7l80b7y4n7km1mrzwrml"))))
     (build-system gnu-build-system)
     (arguments
-     `( #:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath="
-                                               (assoc-ref %outputs "out")
-                                               "/lib"))))
+     `(#:configure-flags (list (string-append "LDFLAGS=-Wl,-rpath="
+                                              (assoc-ref %outputs "out")
+                                              "/lib"))
+       #:make-flags '("CFLAGS=-fPIC")))
     (home-page "http://fallabs.com/qdbm")
     (synopsis "Key-value database")
     (description "QDBM is a library of routines for managing a
-- 
2.25.0