diff mbox series

[bug#39520] gnu: btrfs-progs: Install udev-rules.

Message ID 20200209093842.7882-1-brice@waegenei.re
State Accepted
Headers show
Series [bug#39520] gnu: btrfs-progs: Install udev-rules. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Brice Waegeneire Feb. 9, 2020, 9:38 a.m. UTC
* gnu/packages/linux.scm (btrfs-progs)[arguments]: Add phase
patch-makefile.
[native-inputs]: Add lvm2, eudev.
---
 gnu/packages/linux.scm | 10 +++++++++-
 1 file changed, 9 insertions(+), 1 deletion(-)

Comments

Ludovic Courtès Feb. 14, 2020, 9:59 p.m. UTC | #1
Hi,

Brice Waegeneire <brice@waegenei.re> skribis:

> * gnu/packages/linux.scm (btrfs-progs)[arguments]: Add phase
> patch-makefile.
> [native-inputs]: Add lvm2, eudev.

[...]

> +                  (add-after 'unpack 'patch-makefile
> +                    (lambda* (#:key outputs #:allow-other-keys)
> +                      (substitute* "Makefile"
> +                        (("\\$\\(DESTDIR\\)\\$\\(udevruledir\\)")
> +                         (string-append (assoc-ref outputs "out")
> +                                        "/lib/udev/rules.d")))))

I added a #t return here and committed.

Thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index d7a984f42d..79430dea3e 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4023,6 +4023,12 @@  and copy/paste text in the console and in xterm.")
                "static"))      ; static versions of the binaries in "out"
     (arguments
      '(#:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'patch-makefile
+                    (lambda* (#:key outputs #:allow-other-keys)
+                      (substitute* "Makefile"
+                        (("\\$\\(DESTDIR\\)\\$\\(udevruledir\\)")
+                         (string-append (assoc-ref outputs "out")
+                                        "/lib/udev/rules.d")))))
                  (add-after 'build 'build-static
                    (lambda _ (invoke "make" "static")))
                  (add-after 'install 'install-bash-completion
@@ -4043,7 +4049,7 @@  and copy/paste text in the console and in xterm.")
        #:tests? #f            ; XXX: require the 'btrfs' kernel module.
        #:test-target "test"
        #:parallel-tests? #f)) ; tests fail when run in parallel
-    (inputs `(("e2fsprogs" ,e2fsprogs)
+    (inputs `(("e2fsprogs" ,e2fsprogs)  ; for btrfs-convert
               ("libblkid" ,util-linux)
               ("libblkid:static" ,util-linux "static")
               ("libuuid" ,util-linux)
@@ -4063,6 +4069,8 @@  and copy/paste text in the console and in xterm.")
                      ;; For tests.
                      ("acl" ,acl)
                      ("which" ,which)
+                     ("dmsetup" ,lvm2)
+                     ("udevadm" ,eudev)
                      ;; The tests need 'grep' with perl regexp support.
                      ("grep" ,grep)))
     (home-page "https://btrfs.wiki.kernel.org/index.php/Main_Page")