diff mbox series

[bug#39525,2/2] gnu: git-crypt: Install man page.

Message ID 20200209091528.31755-1-brice@waegenei.re
State Accepted
Headers show
Series [bug#39525,1/2] gnu: git-crypt: Update to 0.6.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Brice Waegeneire Feb. 9, 2020, 9:15 a.m. UTC
* gnu/packages/version-control.scm (git-crypt)[native-inputs]: Add
dockbook-xsl, libxslt.
[arguments]: Add phase patch-makefile.
---
 gnu/packages/version-control.scm | 17 +++++++++++++++--
 1 file changed, 15 insertions(+), 2 deletions(-)

Comments

Nicolas Goaziou Feb. 9, 2020, 11:52 p.m. UTC | #1
Hello,

Brice Waegeneire <brice@waegenei.re> writes:

> * gnu/packages/version-control.scm (git-crypt)[native-inputs]: Add
> dockbook-xsl, libxslt.
> [arguments]: Add phase patch-makefile.

I applied both patches (as 57f90b2a245786b6c6683b0cb95aa79c07273ff4 and
ddc5e7468484b0527e6ee423bc42186283dd9998)... and added a copyright line
for you.

Thank you!

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 7bd0e35c08..776e536e82 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -607,20 +607,33 @@  write native speed custom Git applications in any language with bindings.")
     (inputs
      `(("git" ,git)
        ("openssl" ,openssl)))
+    (native-inputs
+     `(("docbook-xsl" ,docbook-xsl)
+       ("libxslt" ,libxslt)))
     (arguments
      `(#:tests? #f ; No tests.
        #:phases
        (modify-phases %standard-phases
          (delete 'configure)
+         (add-after 'unpack 'patch-makefile
+           (lambda* (#:key inputs #:allow-other-keys)
+             (substitute* "Makefile"
+               (("http://docbook.sourceforge.net/release/xsl/current/manpages/docbook.xsl")
+                (string-append (assoc-ref inputs "docbook-xsl")
+                               "/xml/xsl/docbook-xsl-"
+                               ,(package-version docbook-xsl)
+                               "/manpages/docbook.xsl")))
+             #t))
          (replace 'build
            (lambda _
-             (invoke "make")))
+             (invoke "make" "ENABLE_MAN=yes")))
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out")))
                (invoke "make" "install"
+                       "ENABLE_MAN=yes"
                        (string-append "PREFIX=" out))))))))
-    (home-page "https://www.agwa.name/projects/git-crypt")
+    (home-page "https://www.agwa.name/projects/git-crypt/")
     (synopsis "Transparent encryption of files in a git repository")
     (description "git-crypt enables transparent encryption and decryption of
 files in a git repository.  Files which you choose to protect are encrypted when