diff mbox series

[bug#39523] gnu: password-store: Install fish and zsh completions.

Message ID 20200209091125.29139-1-brice@waegenei.re
State Accepted
Headers show
Series [bug#39523] gnu: password-store: Install fish and zsh completions. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Brice Waegeneire Feb. 9, 2020, 9:11 a.m. UTC
* gnu/packages/password-utils.scm (password-store)[arguments]: Remove
phase install-shell-completions. Adjust make-flags.
---
 gnu/packages/password-utils.scm | 14 ++++----------
 1 file changed, 4 insertions(+), 10 deletions(-)

Comments

Nicolas Goaziou Feb. 10, 2020, 12:10 a.m. UTC | #1
Hello,

Brice Waegeneire <brice@waegenei.re> writes:

> * gnu/packages/password-utils.scm (password-store)[arguments]: Remove
> phase install-shell-completions. Adjust make-flags.

I applied your patch (as df931ac39c40ac8a702e37cb434d9a1016606ed7)...
aaaaaaaand added a copyright line. Phew :)

Thank you!

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index db5f54e1d9..9cfa5ed3a3 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -496,17 +496,11 @@  any X11 window.")
                                 "sed" "tree" "which" "xclip"))))
                (wrap-program (string-append out "/bin/pass")
                  `("PATH" ":" prefix (,(string-join path ":"))))
-               #t)))
-         (add-after 'wrap-path 'install-shell-completions
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out      (assoc-ref outputs "out"))
-                    (bashcomp (string-append out "/etc/bash_completion.d")))
-               ;; TODO: install fish and zsh completions.
-               (mkdir-p bashcomp)
-               (copy-file "src/completion/pass.bash-completion"
-                          (string-append bashcomp "/pass"))
                #t))))
-       #:make-flags (list "CC=gcc" (string-append "PREFIX=" %output))
+       #:make-flags (list "CC=gcc" (string-append "PREFIX=" %output)
+                          "WITH_ALLCOMP=yes"
+                          (string-append "BASHCOMPDIR="
+                                         %output "/etc/bash_completion.d"))
        ;; Parallel tests may cause a race condition leading to a
        ;; timeout in some circumstances.
        #:parallel-tests? #f