diff mbox series

[bug#39453] gnu: Add rust-ctrlc.

Message ID 20200206162918.14165-1-tanguy@bioneland.org
State Accepted
Headers show
Series [bug#39453] gnu: Add rust-ctrlc. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Tanguy LE CARROUR Feb. 6, 2020, 4:29 p.m. UTC
* gnu/packages/crates-io.scm (rust-ctrlc-3.1): New variable.
---
 gnu/packages/crates-io.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

Efraim Flashner Feb. 8, 2020, 7:26 p.m. UTC | #1
closed as requested
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 727e7c9510..a48d614df5 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -1159,6 +1159,32 @@  little-endian.")
      "Types and traits for working with bytes.")
     (license license:expat)))
 
+(define-public rust-ctrlc-3.1
+  (package
+    (name "rust-ctrlc")
+    (version "3.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "ctrlc" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0pnv2g5q73xa0g4g9k31h2fkmk4dabznjhrkqs93d28v5f9920v3"))))
+    (build-system cargo-build-system)
+    (home-page "https://github.com/Detegr/rust-ctrlc")
+    (synopsis "A simple easy to use wrapper around Ctrl-C signal")
+    (description
+     "Cross platform handling of Ctrl-C signals.  set_handler() allows setting
+a handler closure which is executed on Ctrl+C.  On Unix, this corresponds to
+a SIGINT signal. On windows, Ctrl+C corresponds to CTRL_C_EVENT or
+CTRL_BREAK_EVENT.  Setting a handler will start a new dedicated signal
+handling thread where we execute the handler each time we receive
+a Ctrl+C signal. There can only be one handler, you would typically set one
+at the start of your program.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-c2-chacha-0.2
   (package
     (name "rust-c2-chacha")