diff mbox series

[bug#39416] Bulk import of R packages

Message ID 20200206135252.GM2917@zpidnp36
State Accepted
Headers show
Series [bug#39416] Bulk import of R packages | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Lars-Dominik Braun Feb. 6, 2020, 1:52 p.m. UTC
Hi Ricardo,

> Could you please also do the following:
> 
> * modify the description to contain only complete sentences
> * adjust the letter case in the synopsis (CRAN uppercases all initials)
> * adjust the indentation with etc/indent-code.el
> * use @dfn{Some Long Term} (SLT) in descriptions where necessary
> * wrap URLs in the description in Texinfo syntax (especially all the
>   <doi:...> things.
done, I hope I did not miss anything.

Lars

Comments

Ricardo Wurmus Feb. 22, 2020, 7:49 p.m. UTC | #1
Hi Lars,

>> Could you please also do the following:
>>
>> * modify the description to contain only complete sentences
>> * adjust the letter case in the synopsis (CRAN uppercases all initials)
>> * adjust the indentation with etc/indent-code.el
>> * use @dfn{Some Long Term} (SLT) in descriptions where necessary
>> * wrap URLs in the description in Texinfo syntax (especially all the
>>   <doi:...> things.
> done, I hope I did not miss anything.

Thank you for the updated patches. I’ve just pushed variants of these
patches.

There were still quite a few things to change, which is why this took me
so long.  One of the problems was that the descriptions often included
incomplete sentence fragments.

--
Ricardo
diff mbox series

Patch

From e8683cb87a54b57d857689466809dd87ba7ef2d9 Mon Sep 17 00:00:00 2001
From: Lars-Dominik Braun <ldb@leibniz-psychology.org>
Date: Tue, 4 Feb 2020 14:17:17 +0100
Subject: [v2 34/34] gnu: Add package r-irtoys

* gnu/packages/cran.scm (r-irtoys): New variable.
---
 gnu/packages/cran.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 43ce04f826..5d06b8d452 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -20240,3 +20240,35 @@  itemfit and personfit statistics including infit and outfit measures, ICC and
 other plots, automated stepwise item elimination, simulation module for various
 binary data matrices.")
     (license license:gpl3)))
+
+(define-public r-irtoys
+  (package
+    (name "r-irtoys")
+    (version "0.2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "irtoys" version))
+       (sha256
+        (base32
+         "0h6iiaxikhbxhbyksbjnb09qdxinlkwr2v9yzs5wslbni14paq5q"))))
+    (properties `((upstream-name . "irtoys")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-ltm" ,r-ltm) ("r-sm" ,r-sm)))
+    (home-page
+     "https://cran.r-project.org/package=irtoys")
+    (synopsis
+     "Collection of functions related to Item Response Theory (IRT)")
+    (description
+     "This package provides a collection of functions useful in learning and
+practicing IRT, which can be combined into larger programs.  Provides basic CTT
+analysis, a simple common interface to the estimation of item parameters in IRT
+models for binary responses with three different programs (ICL, BILOG-MG, and
+ltm), ability estimation (MLE, BME, EAP, WLE, plausible values), item and
+person fit statistics, scaling methods (MM, MS, Stocking-Lord, and the complete
+Hebaera method), and a rich array of parametric and non-parametric (kernel)
+plots.  Estimates and plots Haberman's interaction model when all items are
+dichotomously scored.")
+    (license license:gpl2+)))
+
-- 
2.20.1