diff mbox series

[bug#39410] gnu: netsurf: Fix entity parsing.

Message ID 20200204050609.27557-1-bavier@member.fsf.org
State Accepted
Headers show
Series [bug#39410] gnu: netsurf: Fix entity parsing. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Eric Bavier Feb. 4, 2020, 5:06 a.m. UTC
From: Eric Bavier <bavier@posteo.net>

From: Eric Bavier <bavier@member.fsf.org>

Follow-up to commit 31afa654c58cd7aa8bd11a771fa6eabcd766d443.

* gnu/packages/web.scm (netsurf)[arguments]: In 'adjust-welcome' phase, ensure
html entities are parsed and find their way back to the output.
---
 gnu/packages/web.scm | 11 +++++++++--
 1 file changed, 9 insertions(+), 2 deletions(-)

Comments

Efraim Flashner Feb. 4, 2020, 11:02 a.m. UTC | #1
I assume this fixes building netsurf on master. Any idea why netsurf
builds on core-updates without this patch?
Efraim Flashner Feb. 4, 2020, 12:25 p.m. UTC | #2
On Tue, Feb 04, 2020 at 01:02:28PM +0200, Efraim Flashner wrote:
> I assume this fixes building netsurf on master. Any idea why netsurf
> builds on core-updates without this patch?

I take it back, with the recent merging of master into core-updates
netsurf failed to build for me.
diff mbox series

Patch

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index f6ae958ae3..60fd5cfd0f 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -6,7 +6,7 @@ 
 ;;; Copyright © 2015, 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2018 Raoul Jean Pierre Bonnal <ilpuccio.febo@gmail.com>
 ;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
-;;; Copyright © 2015, 2016, 2017, 2018, 2019 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Eric Bavier <bavier@posteo.net>
 ;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
 ;;; Copyright © 2016 Sou Bunnbu <iyzsong@gmail.com>
 ;;; Copyright © 2016 Jelle Licht <jlicht@fsfe.org>
@@ -5075,12 +5075,19 @@  w3c webidl files and a binding configuration file.")
                  ;; Leave the DOCTYPE header as is.
                  (display (read-line in 'concat) out)
                  (sxml->xml
-                  (let rec ((sxml (xml->sxml in)))
+                  (let rec ((sxml (xml->sxml in
+					     #:default-entity-handler
+					     (lambda (port name)
+					       (string-append "<ENTITY>"
+							      (symbol->string name)
+							      "</ENTITY>")))))
                     ;; We'd like to use sxml-match here, but it can't
                     ;; match against generic tag symbols...
                     (match sxml
                       (`(div (@ (class "links")) . ,rest)
                        '())
+		      (`(ENTITY ,ent)
+		       `(*ENTITY* ,ent))
                       ((x ...)
                        (map rec x))
                       (x x)))