diff mbox series

[bug#39386] gnu: Add xwrits.

Message ID 20200202010445.GI2935097@sax.terramar.selidor.net
State Accepted
Headers show
Series [bug#39386] gnu: Add xwrits. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Ivan Vilata i Balaguer Feb. 2, 2020, 1:04 a.m. UTC
Hi!  This adds a package definition for the very useful and health-conscious
(if you type a lot) [Xwrits][1] program.  The definition is the result from
some newbie hacking in Guix Days 2020. `:)`

[1]: http://www.lcdf.org/~eddietwo/xwrits/

Comments

Nicolas Goaziou Feb. 2, 2020, 1:14 p.m. UTC | #1
Hello,

Ivan Vilata i Balaguer <ivan@selidor.net> writes:

> Hi!  This adds a package definition for the very useful and health-conscious
> (if you type a lot) [Xwrits][1] program.  The definition is the result from
> some newbie hacking in Guix Days 2020. `:)`
>
> [1]: http://www.lcdf.org/~eddietwo/xwrits/

I added libxinerama input and applied your patch. Thank you.

Regards,
Ivan Vilata i Balaguer Feb. 6, 2020, 9:24 a.m. UTC | #2
Nicolas Goaziou (2020-02-02 14:14:41 +0100) wrote:

> Ivan Vilata i Balaguer <ivan@selidor.net> writes:
> 
> > Hi!  This adds a package definition for the very useful and health-conscious
> > (if you type a lot) [Xwrits][1] program.  The definition is the result from
> > some newbie hacking in Guix Days 2020. `:)`
> >
> > [1]: http://www.lcdf.org/~eddietwo/xwrits/
> 
> I added libxinerama input and applied your patch. Thank you.

Umm, I never noticed it had Xinerama support…  I like how windows stay
consistent between desktops now. `:)`

Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index ecefab1dbb..12f2cb2466 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -30,6 +30,7 @@ 
 ;;; Copyright © 2019 Josh Holland <josh@inv.alid.pw>
 ;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
 ;;; Copyright © 2020 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2020 Ivan Vilata i Balaguer <ivan@selidor.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2005,3 +2006,37 @@  The cutbuffer and clipboard selection are always synchronized.")
 can optionally use some appearance settings from XSettings, tint2 and GTK.")
     (home-page "https://jgmenu.github.io/")
     (license license:gpl2)))
+
+(define-public xwrits
+  (package
+    (name "xwrits")
+    (version "2.26")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://www.lcdf.org/~eddietwo/xwrits/"
+                           "xwrits-" version ".tar.gz"))
+       (sha256
+        (base32 "1n7y0fqpcvmzznvbsn14hzy5ddaa3lilm8aw6ckscqndnh4lijma"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'install 'install-docs
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (doc (string-append out "/share/doc/xwrits")))
+               (install-file "GESTURES" doc)
+               (install-file "README" doc)
+               #t))))))
+    (inputs
+     `(("libx11" ,libx11)))
+    (home-page "https://www.lcdf.org/~eddietwo/xwrits/")
+    (synopsis "Reminds you to take wrist breaks")
+    (description "Xwrits reminds you to take wrist breaks for prevention or
+management of repetitive stress injuries.  When you should take a break, it
+pops up an X window, the warning window.  You click on the warning window,
+then take a break.  The window changes appearance while you take the break.
+It changes again when your break is over.  Then you just resume typing.
+Xwrits hides itself until you should take another break.")
+    (license license:gpl2)))