diff mbox series

[bug#39381,3/3] gnu: godot: Add zenity for showing alerts.

Message ID 20200201130039.9300-3-timotej.lazar@araneo.si
State Accepted
Headers show
Series Update Godot to 3.2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Timotej Lazar Feb. 1, 2020, 1 p.m. UTC
* gnu/packages/game-development.scm (godot)[inputs]: Add zenity.
[arguments]: Wrap godot to look for it in the store.
---
 gnu/packages/game-development.scm | 5 +++++
 1 file changed, 5 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index c9a8b922b4..6fa4fed74f 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -1599,6 +1599,10 @@  games.")
                      (rename-file "godot.x11.tools.64" "godot")
                      (rename-file "godot.x11.tools.32" "godot"))
                  (install-file "godot" bin))
+               ;; Tell Godot where to find zenity for OS.alert().
+               (wrap-program (string-append bin "/godot")
+                 `("PATH" ":" prefix
+                   (,(string-append (assoc-ref %build-inputs "zenity") "/bin"))))
                #t)))
          (add-after 'install 'install-godot-desktop
            (lambda* (#:key outputs #:allow-other-keys)
@@ -1642,6 +1646,7 @@  games.")
               ("pcre2" ,pcre2)
               ("pulseaudio" ,pulseaudio)
               ("wslay" ,wslay)
+              ("zenity" ,zenity)
               ("zstd" ,zstd "lib")))
     (home-page "https://godotengine.org/")
     (synopsis "Advanced 2D and 3D game engine")