diff mbox series

[bug#39348] gnu: go: Update to 1.12.16 [fixes CVE-2018-17075]

Message ID 20200129212101.u6tz2j74ywo4dga5@zdrowyportier.kadziolka.net
State Accepted
Headers show
Series [bug#39348] gnu: go: Update to 1.12.16 [fixes CVE-2018-17075] | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Maja Kądziołka Jan. 29, 2020, 9:21 p.m. UTC
* gnu/packages/golang.scm (go-1.12): Update to 1.12.16.
---
Tested by building `go' and `syncthing' (the latter being a prominent Go
package). Of course, both builds succeeded.
---
 gnu/packages/golang.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Leo Famulari Jan. 30, 2020, 1:28 a.m. UTC | #1
On Wed, Jan 29, 2020 at 10:21:01PM +0100, Jakub Kądziołka wrote:
> * gnu/packages/golang.scm (go-1.12): Update to 1.12.16.
> ---
> Tested by building `go' and `syncthing' (the latter being a prominent Go
> package). Of course, both builds succeeded.

Thanks for the patch and for describing how you tested it!

Pushed as 7037ffe11acd3988e1d9281923c99fc5d74afac2
Maja Kądziołka Jan. 30, 2020, 6:30 p.m. UTC | #2
----- Forwarded message from Leo Famulari <leo@famulari.name> -----

Date: Wed, 29 Jan 2020 20:28:35 -0500
From: Leo Famulari <leo@famulari.name>
To: Jakub Kądziołka <kuba@kadziolka.net>
Cc: 39348@debbugs.gnu.org
Subject: Re: [bug#39348] [PATCH] gnu: go: Update to 1.12.16 [fixes
 CVE-2018-17075]

On Wed, Jan 29, 2020 at 10:21:01PM +0100, Jakub Kądziołka wrote:
> * gnu/packages/golang.scm (go-1.12): Update to 1.12.16.
> ---
> Tested by building `go' and `syncthing' (the latter being a prominent Go
> package). Of course, both builds succeeded.

Thanks for the patch and for describing how you tested it!

Pushed as 7037ffe11acd3988e1d9281923c99fc5d74afac2



----- End forwarded message -----
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index a6b5f2a4cf..9102469749 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -220,7 +220,7 @@  in the style of communicating sequential processes (@dfn{CSP}).")
   (package
     (inherit go-1.4)
     (name "go")
-    (version "1.12.15")
+    (version "1.12.16")
     (source
      (origin
        (method url-fetch)
@@ -228,7 +228,7 @@  in the style of communicating sequential processes (@dfn{CSP}).")
                            name version ".src.tar.gz"))
        (sha256
         (base32
-         "1hw4xjywcl883dnvfbb92w85sy8n231fdri4aynj8xajgr0p9fla"))))
+         "1y0x10fsvgpc1x24b9q9y6kv9b0kwf7879am3p0gym2abgc5wvnf"))))
     (arguments
      (substitute-keyword-arguments (package-arguments go-1.4)
        ((#:phases phases)