diff mbox series

[bug#39331] gnu: Add emacs-persist and emacs-org-drill

Message ID 20200128221944.6791-1-robertsmith@posteo.net
State Accepted
Headers show
Series [bug#39331] gnu: Add emacs-persist and emacs-org-drill | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Robert Smith Jan. 28, 2020, 10:19 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-persist): New variable.
  (emacs-org-drill): New variable.
---
Added emacs-org-drill and its dependency emacs-persist. emacs-org-drill
was previously included in emacs-org-contrib, but was removed in 2019
and placed in a separate melpa package.

 gnu/packages/emacs-xyz.scm | 51 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 51 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e834dfffb3..7054bd0d72 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -58,6 +58,7 @@ 
 ;;; Copyright © 2019 Leo Prikler <leo.prikler@student.tugraz.at>
 ;;; Copyright © 2019 David Wilson <david@daviwil.com>
 ;;; Copyright © 2020 Paul Garlick <pgarlick@tourbillion-technology.com>
+;;; Copyright © 2020 Robert Smith <robertsmith@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -21237,3 +21238,53 @@  mode-line text (lighter) of major and minor modes.")
       (description "@code{unkillable-scratch} helps prevent killing buffers
 matching a given regexp.")
       (license license:gpl2+))))
+
+(define-public emacs-persist
+  (package
+    (name "emacs-persist")
+    (version "0.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://elpa.gnu.org/packages/persist-"
+                           version ".tar"))
+       (sha256
+        (base32 "0gpxy41qawzss2526j9a7lys60vqma1lvamn4bfabwza7gfhac0q"))))
+    (build-system emacs-build-system)
+    (home-page "http://elpa.gnu.org/packages/persist.html")
+    (synopsis "Persist Variables between Emacs Sessions")
+    (description
+     "This package provides variables which persist across sessions.
+Values are stored in a directory in `user-emacs-directory', using
+one file per value.  This makes it easy to delete or remove unused
+variables.")
+    (license license:gpl3+)))
+
+(define-public emacs-org-drill
+  (package
+    (name "emacs-org-drill")
+    ;; Latest version in melpa-stable is from 2016
+    (version "20191219.2100")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://melpa.org/packages/org-drill-"
+			   version ".el"))
+       (sha256
+	    (base32 "0nbsn1vi2g68yvy74r3bmywfkgpm4a5nmx5g9sxy5fb185lrkzc8"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-seq" ,emacs-seq)
+       ("emacs-org" ,emacs-org)
+       ("emacs-persist" ,emacs-persist)))
+    (home-page "https://gitlab.com/phillord/org-drill")
+    (synopsis "Self-testing using spaced repetition")
+    (description
+    "Org-Drill is an extension for Org mode. Org-Drill uses a spaced
+repetition algorithm to conduct interactive drill sessions, using org files as
+sources of facts to be memorised. Each topic is treated as a flash card. The
+material to be remembered is presented to the student in random order. The
+student rates his or her recall of each item, and this information is used to
+schedule the item for later revision.")
+    (license license:gpl3+)))
+