diff mbox series

[bug#39263,1/2] gnu: godot: Update to 3.1.2.

Message ID 20200124150226.27294-1-timotej.lazar@araneo.si
State Accepted
Headers show
Series Update Godot | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Timotej Lazar Jan. 24, 2020, 3:02 p.m. UTC
* gnu/packages/game-development.scm (godot): Update to 3.1.2.
[inputs]: Remove openssl, replaced by a (modified) bundled copy of mbedtls.
[arguments](configure-flags): Remove builtin_openssl flag.
[source]: Don’t try to remove the (now nonexistent) bundled openssl directory.
---
 gnu/packages/game-development.scm | 8 +++-----
 1 file changed, 3 insertions(+), 5 deletions(-)

Comments

Christopher Baines Jan. 25, 2020, 9:16 a.m. UTC | #1
Timotej Lazar <timotej.lazar@araneo.si> writes:

> * gnu/packages/game-development.scm (godot): Update to 3.1.2.
> [inputs]: Remove openssl, replaced by a (modified) bundled copy of mbedtls.
> [arguments](configure-flags): Remove builtin_openssl flag.
> [source]: Don’t try to remove the (now nonexistent) bundled openssl directory.
> ---
>  gnu/packages/game-development.scm | 8 +++-----
>  1 file changed, 3 insertions(+), 5 deletions(-)
>
> diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
> index ee8dea23b5..79e3f6dc6c 100644
> --- a/gnu/packages/game-development.scm
> +++ b/gnu/packages/game-development.scm
> @@ -18,6 +18,7 @@
>  ;;; Copyright © 2019, 2020 Leo Prikler <leo.prikler@student.tugraz.at>
>  ;;; Copyright © 2019 Jethro Cao <jethrocao@gmail.com>
>  ;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
> +;;; Copyright © 2020 Timotej Lazar <timotej.lazar@araneo.si>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -1503,7 +1504,7 @@ games.")
>  (define-public godot
>    (package
>      (name "godot")
> -    (version "3.0.6")
> +    (version "3.1.2")
>      (source (origin
>                (method git-fetch)
>                (uri (git-reference
> @@ -1512,7 +1513,7 @@ games.")
>                (file-name (git-file-name name version))
>                (sha256
>                 (base32
> -                "0g64h0x8dlv6aa9ggfcidk2mknkfl5li7z1phcav8aqp9srj8avf"))
> +                "12305wj2i4067jc50l8r0wmb7zjcna24fli8vb8kiaild0jrlip6"))
>                (modules '((guix build utils)))
>                (snippet
>                 '(begin
> @@ -1527,7 +1528,6 @@ games.")
>                                  "libvorbis"
>                                  "libvpx"
>                                  "libwebp"
> -                                "openssl"
>                                  "opus"
>                                  "zlib"))
>                      #t)))))
> @@ -1550,7 +1550,6 @@ games.")
>                             "builtin_libvorbis=no"
>                             "builtin_libvpx=no"
>                             "builtin_libwebp=no"
> -                           "builtin_openssl=no"
>                             "builtin_opus=no"
>                             "builtin_zlib=no")
>         #:tests? #f ; There are no tests
> @@ -1612,7 +1611,6 @@ games.")
>                ("libxinerama" ,libxinerama)
>                ("libxrandr" ,libxrandr)
>                ("mesa" ,mesa)
> -              ("openssl" ,openssl)
>                ("opusfile" ,opusfile)
>                ("pulseaudio" ,pulseaudio)))
>      (home-page "https://godotengine.org/")

I did have a look if the package builds with the mbedtls-apache package,
rather than using the included source code, and it looks to. Although
I'm aware that [1] says there are modifications.

1: https://github.com/godotengine/godot/tree/master/thirdparty#mbedtls
diff mbox series

Patch

diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index ee8dea23b5..79e3f6dc6c 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -18,6 +18,7 @@ 
 ;;; Copyright © 2019, 2020 Leo Prikler <leo.prikler@student.tugraz.at>
 ;;; Copyright © 2019 Jethro Cao <jethrocao@gmail.com>
 ;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2020 Timotej Lazar <timotej.lazar@araneo.si>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1503,7 +1504,7 @@  games.")
 (define-public godot
   (package
     (name "godot")
-    (version "3.0.6")
+    (version "3.1.2")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -1512,7 +1513,7 @@  games.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0g64h0x8dlv6aa9ggfcidk2mknkfl5li7z1phcav8aqp9srj8avf"))
+                "12305wj2i4067jc50l8r0wmb7zjcna24fli8vb8kiaild0jrlip6"))
               (modules '((guix build utils)))
               (snippet
                '(begin
@@ -1527,7 +1528,6 @@  games.")
                                 "libvorbis"
                                 "libvpx"
                                 "libwebp"
-                                "openssl"
                                 "opus"
                                 "zlib"))
                     #t)))))
@@ -1550,7 +1550,6 @@  games.")
                            "builtin_libvorbis=no"
                            "builtin_libvpx=no"
                            "builtin_libwebp=no"
-                           "builtin_openssl=no"
                            "builtin_opus=no"
                            "builtin_zlib=no")
        #:tests? #f ; There are no tests
@@ -1612,7 +1611,6 @@  games.")
               ("libxinerama" ,libxinerama)
               ("libxrandr" ,libxrandr)
               ("mesa" ,mesa)
-              ("openssl" ,openssl)
               ("opusfile" ,opusfile)
               ("pulseaudio" ,pulseaudio)))
     (home-page "https://godotengine.org/")