diff mbox series

[bug#39262] gnu: geoclue: Update to 2.5.5

Message ID 20200124125144.2668-1-mjbecze@riseup.net
State Accepted
Headers show
Series [bug#39262] gnu: geoclue: Update to 2.5.5 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Martin Becze Jan. 24, 2020, 12:51 p.m. UTC
* gnu/packages/gnome.scm (geoclue): Update to 2.5.5
---
 gnu/packages/gnome.scm | 33 +++++++++++----------------------
 1 file changed, 11 insertions(+), 22 deletions(-)

Comments

Jonathan Brielmaier Jan. 24, 2020, 1:44 p.m. UTC | #1
On 24.01.20 13:51, Martin Becze wrote:
> -       (uri (string-append "https://www.freedesktop.org/software/" name
> -                           "/releases/" (version-major+minor version) "/"
> -                           name "-" version ".tar.xz"))
> +       (uri (string-append "https://gitlab.freedesktop.org/geoclue/geoclue/-/archive/" version "/geoclue-" version ".tar.bz2"))

Please wrap the lines.


>       (home-page "https://www.freedesktop.org/wiki/Software/GeoClue/")

They moved to Gitlab, so there new homepage would be something like:
https://gitlab.freedesktop.org/geoclue/geoclue Would be good to include.

Did you test if it works together with ModemManager? Maybe with a LTE
card in a laptop or so.
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index e843bdfe08..4710eb1db3 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -40,7 +40,7 @@ 
 ;;; Copyright © 2019 Jelle Licht <jlicht@fsfe.org>
 ;;; Copyright © 2019 Jonathan Frederickson <jonathan@terracrypt.net>
 ;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
-;;; Copyright © 2019 Martin Becze <mjbecze@riseup.net>
+;;; Copyright © 2019, 2020 Martin Becze <mjbecze@riseup.net>
 ;;; Copyright © 2019 David Wilson <david@daviwil.com>
 ;;; Copyright © 2019, 2020 Raghav Gururajan <raghavgururajan@disroot.org>
 ;;; Copyright © 2019 Jonathan Brielmaier <jonathan.brielmaier@web.de>
@@ -4074,40 +4074,29 @@  output devices.")
 (define-public geoclue
   (package
     (name "geoclue")
-    (version "2.4.8")
+    (version "2.5.5")
     (source
      (origin
        (method url-fetch)
-       (uri (string-append "https://www.freedesktop.org/software/" name
-                           "/releases/" (version-major+minor version) "/"
-                           name "-" version ".tar.xz"))
+       (uri (string-append "https://gitlab.freedesktop.org/geoclue/geoclue/-/archive/" version "/geoclue-" version ".tar.bz2"))
        (sha256
         (base32
-         "08yg1r7m0n9hwyvcy769qkmkf8lslqwv69cjfffwnc3zm5km25qj"))
+         "1b7jqrsn4x7mxjxj8hvb2dl2cmhrpb9vibs4rvkkanky5nsx3sai"))
        (patches (search-patches "geoclue-config.patch"))))
-    (build-system glib-or-gtk-build-system)
+    (build-system meson-build-system)
     (arguments
-     '(;; The tests want to run the system bus.
-       #:tests? #f
-       #:configure-flags (list ;; Disable bits requiring ModemManager.
-                               "--disable-3g-source"
-                               "--disable-cdma-source"
-                               "--disable-modem-gps-source"
-                               "--with-dbus-service-user=geoclue")
-       #:phases
-       (modify-phases %standard-phases
-         (add-before 'configure 'patch-/bin/true
-                     (lambda _
-                       (substitute* "configure"
-                         (("/bin/true") (which "true")))
-                       #t)))))
+     '(#:configure-flags (list "-Dbus-srv-user=geoclue")))
     (native-inputs
      `(("pkg-config" ,pkg-config)
        ("gobject-introspection" ,gobject-introspection)
+       ("modem-manager" ,modem-manager)
+       ("libnotify" ,libnotify)
+       ("gtk-doc", gtk-doc)
        ("intltool" ,intltool)))
     (inputs
      `(("avahi" ,avahi)
-       ("glib" ,glib)
+       ("glib:bin" ,glib "bin")
+       ("glib-networking" ,glib-networking)
        ("json-glib" ,json-glib)
        ("libsoup" ,libsoup)))
     (home-page "https://www.freedesktop.org/wiki/Software/GeoClue/")