diff mbox series

[bug#39228] gnu: Add libvnc.

Message ID 20200121211056.7192-1-h.goebel@crazy-compilers.com
State Accepted
Headers show
Series [bug#39228] gnu: Add libvnc. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Hartmut Goebel Jan. 21, 2020, 9:10 p.m. UTC
* gnu/packages/libvnc.scm: New file.
* gnu/lokal.mk: Add it.
---
 gnu/local.mk            |  1 +
 gnu/packages/libvnc.scm | 63 +++++++++++++++++++++++++++++++++++++++++
 2 files changed, 64 insertions(+)
 create mode 100644 gnu/packages/libvnc.scm

Comments

Leo Famulari Jan. 21, 2020, 9:57 p.m. UTC | #1
On Tue, Jan 21, 2020 at 10:10:56PM +0100, Hartmut Goebel wrote:
> * gnu/packages/libvnc.scm: New file.
> * gnu/lokal.mk: Add it.

s/lokal/local

> +(define-public libvnc
> +  (package
> +    (name "libvnc")

Overall LGTM.

I notice we have a package module 'gnu/packages/tigervnc.scm'. Maybe we
can combine that module with this one as 'gnu/packages/vnc.scm'?
Hartmut Goebel Jan. 22, 2020, 8:47 a.m. UTC | #2
Am 21.01.20 um 22:57 schrieb Leo Famulari:
> I notice we have a package module 'gnu/packages/tigervnc.scm'. Maybe we
> can combine that module with this one as 'gnu/packages/vnc.scm'?

I thought about this, too, but hesitated. The module `tighervnc` seems
to not be used anywhere, thus renaming it would be easy.

If this is okay, I would go forward and:

1. renaming `tigervnc.scm` into `vnc.scm` (as proposed by you)

2. add libvnc to this module.

3. push to master.
Efraim Flashner Jan. 22, 2020, 9:16 a.m. UTC | #3
On Wed, Jan 22, 2020 at 09:47:58AM +0100, Hartmut Goebel wrote:
> Am 21.01.20 um 22:57 schrieb Leo Famulari:
> > I notice we have a package module 'gnu/packages/tigervnc.scm'. Maybe we
> > can combine that module with this one as 'gnu/packages/vnc.scm'?
> 
> I thought about this, too, but hesitated. The module `tighervnc` seems
> to not be used anywhere, thus renaming it would be easy.
> 
> If this is okay, I would go forward and:
> 
> 1. renaming `tigervnc.scm` into `vnc.scm` (as proposed by you)
> 
> 2. add libvnc to this module.
> 
> 3. push to master.
> 

Sounds good to me
Hartmut Goebel Jan. 22, 2020, 12:09 p.m. UTC | #4
Done. Pushed as a789f654a0f370720b2c6b7856b9971dcc1d5eb1

Thanks for the review.
Jonathan Brielmaier Jan. 22, 2020, 12:17 p.m. UTC | #5
94c7ef932a5857020c2a5349ff1970b1809a080e which is right before adding
libvnc has the wrong commit headline:

gnu: Rename module gnutls to tls.

should be

gnu: Rename module tigervnc to vnc.

Just for the record :P

On 22.01.20 13:09, Hartmut Goebel wrote:
> Done. Pushed as a789f654a0f370720b2c6b7856b9971dcc1d5eb1
>
> Thanks for the review.
>
Hartmut Goebel Jan. 22, 2020, 12:21 p.m. UTC | #6
Am 22.01.20 um 13:17 schrieb Jonathan Brielmaier:
> gnu: Rename module gnutls to tls.
>
> should be
>
> gnu: Rename module tigervnc to vnc.

ARGL! I should not do this kind of work when traveling.

@efraim: Any chance to clean this up?
Leo Famulari Jan. 22, 2020, 5:33 p.m. UTC | #7
On Wed, Jan 22, 2020 at 01:21:59PM +0100, Hartmut Goebel wrote:
> Am 22.01.20 um 13:17 schrieb Jonathan Brielmaier:
> > gnu: Rename module gnutls to tls.
> >
> > should be
> >
> > gnu: Rename module tigervnc to vnc.
> 
> ARGL! I should not do this kind of work when traveling.
> 
> @efraim: Any chance to clean this up?

We don't rewrite the commits after they are pushed to Savannah's master
branch. So, it's important to be careful when pushing, but please "don't
beat yourself up" over this :)
Jonathan Brielmaier Jan. 22, 2020, 5:43 p.m. UTC | #8
On 22.01.20 18:33, Leo Famulari wrote:
> On Wed, Jan 22, 2020 at 01:21:59PM +0100, Hartmut Goebel wrote:
>> Am 22.01.20 um 13:17 schrieb Jonathan Brielmaier:
>>> gnu: Rename module gnutls to tls.
>>>
>>> should be
>>>
>>> gnu: Rename module tigervnc to vnc.
>>
>> ARGL! I should not do this kind of work when traveling.
>>
>> @efraim: Any chance to clean this up?
>
> We don't rewrite the commits after they are pushed to Savannah's master
> branch. So, it's important to be careful when pushing, but please "don't
> beat yourself up" over this :)
>

As well as the body of the commit message is correct:

* gnu/packages/tigervnc.scm: Rename to...
* gnu/packages/vnc.scm: ... this.  Change module name accordingly. Sort
   used modules.
* gnu-system.am (GNU_SYSTEM_MODULES): Rename tigervnc module to vnc.
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 286bcb67dd..edc3dda97e 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -311,6 +311,7 @@  GNU_SYSTEM_MODULES =				\
   %D%/packages/libunistring.scm			\
   %D%/packages/libusb.scm			\
   %D%/packages/libunwind.scm			\
+  %D%/packages/libvnc.scm			\
   %D%/packages/lighting.scm                     \
   %D%/packages/linux.scm			\
   %D%/packages/lirc.scm				\
diff --git a/gnu/packages/libvnc.scm b/gnu/packages/libvnc.scm
new file mode 100644
index 0000000000..74a62c2483
--- /dev/null
+++ b/gnu/packages/libvnc.scm
@@ -0,0 +1,63 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2017, 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages libvnc)
+  #:use-module (guix build-system cmake)
+  #:use-module (guix git-download)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages)
+  #:use-module (guix utils)
+  #:use-module (gnu packages)
+  #:use-module (gnu packages compression)
+  #:use-module (gnu packages gnupg)
+  #:use-module (gnu packages image)
+  #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages sdl)
+  #:use-module (gnu packages tls))
+
+(define-public libvnc
+  (package
+    (name "libvnc")
+    (version "0.9.12")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/LibVNC/libvncserver.git")
+             (commit (string-append "LibVNCServer-" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1226hb179l914919f5nm2mlf8rhaarqbf48aa649p4rwmghyx9vm"))))
+    (build-system cmake-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("gnutls" ,gnutls)
+       ("libgcrypt" ,libgcrypt)
+       ("libjpeg" ,libjpeg)
+       ("libpng" ,libpng)
+       ("lzo" ,lzo)
+       ("sdl2" ,sdl2)))
+    (home-page "https://libvnc.github.io/")
+    (synopsis "Cross-platform C libraries for implementing VNC server or
+client")
+    (description "This package provides @code{LibVNCServer} and
+@code{LibVNCClient}.  These are cross-platform C libraries that allow you to
+easily implement VNC server or client functionality in your program.")
+    (license ;; GPL for programs, FDL for documentation
+     (list license:gpl2+ license:fdl1.2+))))