diff mbox series

[bug#39216] gnu: Add python-bonsai

Message ID 20200121105222.24907-1-ldb@leibniz-psychology.org
State Accepted
Headers show
Series [bug#39216] gnu: Add python-bonsai | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Lars-Dominik Braun Jan. 21, 2020, 10:52 a.m. UTC
* gnu/packages/python-xyz.scm (python-bonsai): New variable
---
 gnu/packages/python-xyz.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

Comments

Marius Bakke Jan. 30, 2020, 12:01 p.m. UTC | #1
Hello Lars,

Lars-Dominik Braun <ldb@leibniz-psychology.org> writes:

> * gnu/packages/python-xyz.scm (python-bonsai): New variable

I think openldap.scm is better suited for this package, so that we don't
have to import two more modules into the monster python-xyz.scm.

Please also add a copyright line for yourself, and make sure to fix
issues reported by 'guix lint python-bonsai'.

[...]

> +    (synopsis
> +      "Python 3 module for accessing LDAP directory servers.")

s/Python 3/Python/

or even "Access LDAP directory servers from Python".

Can you send an updated patch?  TIA!
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 715a0109f7..8fd11d5b48 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -95,6 +95,7 @@ 
   #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages crypto)
+  #:use-module (gnu packages cyrus-sasl)
   #:use-module (gnu packages databases)
   #:use-module (gnu packages dbm)
   #:use-module (gnu packages file)
@@ -124,6 +125,7 @@ 
   #:use-module (gnu packages networking)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages openstack)
+  #:use-module (gnu packages openldap)
   #:use-module (gnu packages pcre)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
@@ -17315,3 +17317,30 @@  tests.")
 GSSAPI C libraries.  While it focuses on the Kerberos mechanism, it should
 also be useable with other GSSAPI mechanisms.")
     (license license:isc)))
+
+(define-public python-bonsai
+  (package
+    (name "python-bonsai")
+    (version "1.1.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "bonsai" version))
+        (sha256
+          (base32
+            "0pfzlbri5rfblb4qfvcx46gx4y6z9h057xllmmz47q2qifvs6kfg"))))
+    (build-system python-build-system)
+    (inputs
+     `(("mit-krb5" ,mit-krb5)
+       ("cyrus-sasl" ,cyrus-sasl)
+       ("openldap" ,openldap)))
+    ;; disabling tests, since they require docker and extensive setup
+    (arguments `(#:tests? #f))
+    (home-page "https://github.com/noirello/bonsai")
+    (synopsis
+      "Python 3 module for accessing LDAP directory servers.")
+    (description
+      "This is a module for handling LDAP operations in Python. LDAP entries
+are mapped to a special Python case-insensitive dictionary, tracking the
+changes of the dictionary to modify the entry on the server easily.")
+    (license license:expat)))