diff mbox series

[bug#39197,core-updates,1/4] gnu: RHash: Do not use git-fetch, but provide a fallback URL.

Message ID 20200119232006.12303-1-mbakke@fastmail.com
State Accepted
Headers show
Series Replace libjpeg with libjpeg-turbo | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job

Commit Message

Marius Bakke Jan. 19, 2020, 11:20 p.m. UTC
* gnu/packages/crypto.scm (rhash)[source]: Change to URL-FETCH.
---
 gnu/packages/crypto.scm | 18 ++++++++++++------
 1 file changed, 12 insertions(+), 6 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 276612f887..9a545e7311 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -14,6 +14,7 @@ 
 ;;; Copyright © 2018 Tim Gesthuizen <tim.gesthuizen@yahoo.de>
 ;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
 ;;; Copyright © 2019 Tanguy Le Carrour <tanguy@bioneland.org>
+;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -711,14 +712,19 @@  BLAKE.")
     (version "1.3.9")
     (source
      (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/rhash/RHash")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
+       (method url-fetch)
+       ;; Note: This package is a dependency of CMake, which is needed to build
+       ;; libjpeg-turbo and ultimately 'git-minimal', so we cannot use 'git-fetch'
+       ;; here.  Use the generated tarball with a Debian fallback for now; upstream
+       ;; is aware of the problem: <https://github.com/rhash/RHash/issues/108>.
+       (uri (list (string-append "https://github.com/rhash/RHash/archive/v"
+                                 version ".tar.gz")
+                  (string-append "http://ftp.debian.org/debian/pool/main/r/rhash/"
+                                 "rhash_" version ".orig.tar.gz")))
+       (file-name (string-append "rhash-" version ".tar.gz"))
        (sha256
         (base32
-         "06i49x1l21h2q7pfnf4crbmjyg8b9ad0qs10ywyyn5sjpi0c21wq"))))
+         "1xn9fqa6rlnhsbgami45g82dlw9i1skg2sri3ydiinwak5ph1ca2"))))
     (build-system gnu-build-system)
     (arguments
      `(#:make-flags