diff mbox series

[bug#39191] gnu: Add bvi.

Message ID 20200119124410.i3p2gxzrsgfs2rcn@zdrowyportier.kadziolka.net
State Accepted
Headers show
Series [bug#39191] gnu: Add bvi. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job

Commit Message

Maja Kądziołka Jan. 19, 2020, 12:44 p.m. UTC
* gnu/packages/hexedit.scm (bvi): New variable.
---
 gnu/packages/hexedit.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

Marius Bakke Jan. 27, 2020, 11:26 p.m. UTC | #1
Jakub Kądziołka <kuba@kadziolka.net> writes:

> * gnu/packages/hexedit.scm (bvi): New variable.

Applied with a copyright line, changed license to GPL3+ as per the
source code headers, and added some markup to the description.

Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/hexedit.scm b/gnu/packages/hexedit.scm
index 9aea8e8700..39dcb2e0f7 100644
--- a/gnu/packages/hexedit.scm
+++ b/gnu/packages/hexedit.scm
@@ -80,3 +80,25 @@  low-level functionality of a debugger with the usability of an @dfn{Integrated
 Development Environment} (IDE).")
     (home-page "http://hte.sourceforge.net/")
     (license license:gpl2)))
+
+(define-public bvi
+  (package
+    (name "bvi")
+    (version "1.4.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://sourceforge/bvi/bvi/" version
+                    "/bvi-" version ".src.tar.gz"))
+              (sha256
+               (base32
+                "0a0yl0dcyff31k3dr4dpgqmlwygp8iaslnr5gmb6814ylxf2ad9h"))))
+    (build-system gnu-build-system)
+    (arguments '(#:tests? #f))          ; no check target
+    (inputs
+     `(("ncurses" ,ncurses)))
+    (synopsis "binary file editor")
+    (description "bvi is a display-oriented editor for binary files, based on
+the vi text editor.")
+    (home-page "http://bvi.sourceforge.net/")
+    (license license:gpl3)))