diff mbox series

[bug#39146] gnu: icecat: Remove compiler paths from about:buildconfig

Message ID 20200115222115.322ymuuqkwlnbl3v@zdrowyportier.kadziolka.net
State Accepted
Headers show
Series [bug#39146] gnu: icecat: Remove compiler paths from about:buildconfig | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Maja Kądziołka Jan. 15, 2020, 10:21 p.m. UTC
* gnu/packages/gnuzilla.scm
  (icecat)[arguments](dont-store-compiler-paths): New phase.
---
 gnu/packages/gnuzilla.scm | 10 ++++++++++
 1 file changed, 10 insertions(+)

Comments

Maja Kądziołka Feb. 26, 2020, 9:33 p.m. UTC | #1
Pushed as 37db2370db884ceac3bc97123aaaed84377398eb, closing.

Regards,
Jakub Kądziołka
diff mbox series

Patch

diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index c619cd5d55..ae155e51ba 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -890,6 +890,16 @@  from forcing GEXP-PROMISE."
              (substitute* '("browser/confvars.sh")
                (("MOZ_SERVICES_SYNC=0") "MOZ_SERVICES_SYNC=1"))
              #t))
+         (add-after 'unpack 'dont-store-compiler-paths
+           (lambda _
+             ;; Remove references to the compilers used from the output. Reduces
+             ;; `guix size icecat' by 1 GiB on x86-64.
+             (let ((zap "Store reference removed"))
+               (substitute* "toolkit/content/buildconfig.html"
+                 (("@CC@") zap)
+                 (("@CXX@") zap)
+                 (("@RUSTC@") zap)
+                 (("@MOZ_CONFIGURE_OPTIONS@") zap)))))
          (add-after 'unpack 'apply-guix-specific-patches
            (lambda* (#:key inputs native-inputs #:allow-other-keys)
              (let ((patch (string-append (assoc-ref (or native-inputs inputs)