diff mbox series

[bug#39129] gnu: mutt: Enable Autocrypt support.

Message ID 20200114014936.GA3339771@sax.terramar.selidor.net
State Accepted
Headers show
Series [bug#39129] gnu: mutt: Enable Autocrypt support. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Ivan Vilata i Balaguer Jan. 14, 2020, 1:49 a.m. UTC
Hi!  The attached patch enables Mutt 1.13's new support for Autocrypt:
<http://www.mutt.org/doc/manual/#autocryptdoc>

Cheers!

Comments

Ludovic Courtès Feb. 4, 2020, 11:20 p.m. UTC | #1
Bona nit Ivan!  :-)

Ivan Vilata i Balaguer <ivan@selidor.net> skribis:

> From 52e44c98e3986b8330702c090a6b2e7246ee9a5a Mon Sep 17 00:00:00 2001
> From: Ivan Vilata-i-Balaguer <ivan@selidor.net>
> Date: Mon, 13 Jan 2020 20:44:05 -0500
> Subject: [PATCH] gnu: mutt: Enable Autocrypt support.
>
> * gnu/packages/mail.scm (mutt)[inputs]: Add libidn2 and sqlite.
> [arguments]<#:configure-flags>: Add "--enable-autocrypt", "--with-sqlite3" and
> "--with-idn2".

Applied, thanks!

Ludo'.
Ivan Vilata i Balaguer Feb. 5, 2020, 11:08 p.m. UTC | #2
Ludovic Courtès (2020-02-05 00:20:53 +0100) wrote:

> Bona nit Ivan!  :-)
> 
> Ivan Vilata i Balaguer <ivan@selidor.net> skribis:
> 
> > From 52e44c98e3986b8330702c090a6b2e7246ee9a5a Mon Sep 17 00:00:00 2001
> > From: Ivan Vilata-i-Balaguer <ivan@selidor.net>
> > Date: Mon, 13 Jan 2020 20:44:05 -0500
> > Subject: [PATCH] gnu: mutt: Enable Autocrypt support.
> >
> > * gnu/packages/mail.scm (mutt)[inputs]: Add libidn2 and sqlite.
> > [arguments]<#:configure-flags>: Add "--enable-autocrypt", "--with-sqlite3" and
> > "--with-idn2".
> 
> Applied, thanks!
> 
> Ludo'.

Working flawlessly, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 7d56949ae9..88c21a0e85 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -380,9 +380,11 @@  aliasing facilities to work just as they would on normal mail.")
      `(("cyrus-sasl" ,cyrus-sasl)
        ("gdbm" ,gdbm)
        ("gpgme" ,gpgme)
+       ("libidn2" ,libidn2)
        ("ncurses" ,ncurses)
        ("openssl" ,openssl)
-       ("perl" ,perl)))
+       ("perl" ,perl)
+       ("sqlite" ,sqlite)))
     (arguments
      `(#:configure-flags '("--enable-smtp"
                            "--enable-imap"
@@ -390,8 +392,11 @@  aliasing facilities to work just as they would on normal mail.")
                            "--enable-gpgme"
                            "--enable-hcache" ; for header caching
                            "--enable-sidebar"
+                           "--enable-autocrypt"
                            "--with-ssl"
                            "--with-sasl"
+                           "--with-sqlite3" ; required for Autocrypt
+                           "--with-idn2" ; recommended for Autocrypt
                            ;; so that mutt does not check whether the path
                            ;; exists, which it does not in the chroot
                            "--with-mailpath=/var/mail")))