diff mbox series

[bug#39125] gnu: termite: Open links properly without xdg-utils in profile

Message ID 20200113235037.idus3ggrytfryq5q@zdrowyportier.kadziolka.net
State Accepted
Headers show
Series [bug#39125] gnu: termite: Open links properly without xdg-utils in profile | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Maja Kądziołka Jan. 13, 2020, 11:50 p.m. UTC
* gnu/packages/terminals.scm (termite)[inputs]: Add XDG-UTILS.
  [arguments](patch-xdg-open): New phase.
---
 gnu/packages/terminals.scm | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Marius Bakke Jan. 27, 2020, 11:21 p.m. UTC | #1
Jakub Kądziołka <kuba@kadziolka.net> writes:

> * gnu/packages/terminals.scm (termite)[inputs]: Add XDG-UTILS.
>   [arguments](patch-xdg-open): New phase.

Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/terminals.scm b/gnu/packages/terminals.scm
index b5c3b69f53..dae14aee8f 100644
--- a/gnu/packages/terminals.scm
+++ b/gnu/packages/terminals.scm
@@ -17,6 +17,7 @@ 
 ;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
 ;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
 ;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
+;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -138,6 +139,11 @@  configurable through a graphical wizard.")
     (arguments
       `(#:phases
         (modify-phases %standard-phases
+          (add-after 'unpack 'patch-xdg-open
+            (lambda _
+              (substitute* "termite.cc"
+                (("xdg-open") (which "xdg-open")))
+              #t))
           (delete 'configure))
         #:tests? #f
         ;; This sets the destination when installing the necessary terminal
@@ -150,6 +156,7 @@  configurable through a graphical wizard.")
     (inputs
      `(("vte" ,vte-ng)
        ("gtk+" ,gtk+)
+       ("xdg-utils" ,xdg-utils)
        ("ncurses" ,ncurses)))
     (native-inputs
      `(("pkg-config" ,pkg-config)))