diff mbox series

[bug#39032] gnu: Add ghc-html-conduit.

Message ID 20200108093537.16884-1-brown121407@member.fsf.org
State Accepted
Headers show
Series [bug#39032] gnu: Add ghc-html-conduit. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Alexandru-Sergiu Marton Jan. 8, 2020, 9:35 a.m. UTC
* gnu/packages/haskell-web.scm (ghc-html-conduit): New variable.
---
 gnu/packages/haskell-web.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)

Comments

Marius Bakke March 29, 2020, 7:13 p.m. UTC | #1
Alexandru-Sergiu Marton <brown121407@gmail.com> writes:

> * gnu/packages/haskell-web.scm (ghc-html-conduit): New variable.

Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 5888e8542e..6773455f3b 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -751,6 +751,42 @@  Haskell.")
 documents.")
     (license license:bsd-3)))
 
+(define-public ghc-html-conduit
+  (package
+    (name "ghc-html-conduit")
+    (version "1.3.2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/html-conduit/"
+             "html-conduit-" version ".tar.gz"))
+       (sha256
+        (base32
+         "196c8zcnjp1pc5qvqxd8arx3xkw0a90rvg9mmiw2l4zwnx65709n"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-resourcet" ,ghc-resourcet)
+       ("ghc-conduit" ,ghc-conduit)
+       ("ghc-xml-conduit" ,ghc-xml-conduit)
+       ("ghc-xml-types" ,ghc-xml-types)
+       ("ghc-attoparsec" ,ghc-attoparsec)
+       ("ghc-conduit-extra" ,ghc-conduit-extra)))
+    (native-inputs
+     `(("ghc-hspec" ,ghc-hspec)
+       ("ghc-hunit" ,ghc-hunit)))
+    (home-page "https://github.com/snoyberg/xml")
+    (synopsis
+     "Parse HTML documents using xml-conduit datatypes")
+    (description
+     "This package provides a parser for HTML documents that uses
+tagstream-conduit.  It automatically balances mismatched tags, so that
+there shouldn't be any parse failures.  It does not handle a full HTML
+document rendering, such as adding missing html and head tags.  Note that,
+since version 1.3.1, it uses an inlined copy of tagstream-conduit with
+entity decoding bugfixes applied.")
+    (license license:expat)))
+
 (define-public ghc-blaze-html
   (package
     (name "ghc-blaze-html")