diff mbox series

[bug#39005,03/22] gnu: Add libnatpmp

Message ID 20200107101741.970-3-tona_kosmicznego_smiecia@interia.pl
State Accepted
Headers show
Series [bug#39005,01/22] gnu: jami: Bump to 20191128.1.4c44bb7. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Jan Wielkiewicz Jan. 7, 2020, 10:17 a.m. UTC
---
 gnu/packages/networking.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 482305de35..76a36111f1 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -367,6 +367,32 @@  between different versions of ØMQ.")
 files contain direct mappings of the abstractions provided by the ØMQ C API.")
       (license license:expat))))
 
+(define-public libnatpmp
+  (package
+    (name "libnatpmp")
+    (version "20150609")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+		    "http://miniupnp.free.fr/files/"
+		    name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1c1n8n7mp0amsd6vkz32n8zj3vnsckv308bb7na0dg0r8969rap1"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+		      (delete 'configure)
+		      (delete 'check))
+       #:make-flags
+       (list (string-append "PREFIX=" (assoc-ref %outputs "out")))))
+    (home-page "http://miniupnp.free.fr/libnatpmp.html")
+    (synopsis "C Library implementing NAT-PMP")
+    (description
+     "libnatpmp is a portable and asynchronous implementaiton of the NAT Port Mapping Protocol (NAT-PMP) written in C.")
+    (license license:bsd-3)))
+
 (define-public librdkafka
   (package
     (name "librdkafka")