diff mbox series

[bug#38995] gnu: Add python-git-multimail.

Message ID 20200106201030.4520-1-mail@cbaines.net
State Accepted
Headers show
Series [bug#38995] gnu: Add python-git-multimail. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Christopher Baines Jan. 6, 2020, 8:10 p.m. UTC
* gnu/packages/version-control.scm (python-git-multimail): New variable.
---
 gnu/packages/version-control.scm | 43 ++++++++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)

Comments

Ludovic Courtès Jan. 11, 2020, 9:42 p.m. UTC | #1
Hi Chris!

Christopher Baines <mail@cbaines.net> skribis:

> * gnu/packages/version-control.scm (python-git-multimail): New variable.

[...]

> +             (substitute* "git-multimail/git_multimail.py"
> +               (("GIT_EXECUTABLE = 'git'")
> +                (string-append "GIT_EXECUTABLE = '"
> +                               (assoc-ref inputs "git") "/bin/git"
> +                               "'"))
> +               (("/usr/sbin/sendmail")
> +                (string-append (assoc-ref inputs "sendmail")
> +                               "/usr/sbin/sendmail',
> +        '/usr/sbin/sendmail")))

The second clause is intriguing, but as long as it has the intended
effect, LGTM!  :-)

Ludo’.
Christopher Baines Jan. 16, 2020, 9:32 p.m. UTC | #2
Ludovic Courtès <ludo@gnu.org> writes:

> Hi Chris!
>
> Christopher Baines <mail@cbaines.net> skribis:
>
>> * gnu/packages/version-control.scm (python-git-multimail): New variable.
>
> [...]
>
>> +             (substitute* "git-multimail/git_multimail.py"
>> +               (("GIT_EXECUTABLE = 'git'")
>> +                (string-append "GIT_EXECUTABLE = '"
>> +                               (assoc-ref inputs "git") "/bin/git"
>> +                               "'"))
>> +               (("/usr/sbin/sendmail")
>> +                (string-append (assoc-ref inputs "sendmail")
>> +                               "/usr/sbin/sendmail',
>> +        '/usr/sbin/sendmail")))
>
> The second clause is intriguing, but as long as it has the intended
> effect, LGTM!  :-)

I was thinking something about preserving the existing behaviour when I
kept /usr/sbin/sendmail in the list, but that doesn't make sense, as the
list is searched in order, and sendmail from the Guix package will
always be present.

I've removed the odd bit, and pushed this as
add8d50911f55464a1ecd003521997d6c7d912f3 now.

Thanks for taking a look!

Chris
diff mbox series

Patch

diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index d354a807a3..9188e642a7 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -72,6 +72,7 @@ 
   #:use-module (gnu packages guile)
   #:use-module (gnu packages image)
   #:use-module (gnu packages linux)
+  #:use-module (gnu packages mail)
   #:use-module (gnu packages maths)
   #:use-module (gnu packages nano)
   #:use-module (gnu packages ncurses)
@@ -782,6 +783,48 @@  collaboration using typical untrusted file hosts or services.")
 a built-in cache to decrease server I/O pressure.")
     (license license:gpl2)))
 
+(define-public python-git-multimail
+  (package
+    (name "python-git-multimail")
+    (version "1.5.0.post1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "git-multimail" version))
+       (sha256
+        (base32
+         "1zkrbsa70anwpw86ysfwalrb7nsr064kygfiyikyq1pl9pcl969y"))))
+    (build-system python-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch
+           (lambda* (#:key inputs #:allow-other-keys)
+             (substitute* "git-multimail/git_multimail.py"
+               (("GIT_EXECUTABLE = 'git'")
+                (string-append "GIT_EXECUTABLE = '"
+                               (assoc-ref inputs "git") "/bin/git"
+                               "'"))
+               (("/usr/sbin/sendmail")
+                (string-append (assoc-ref inputs "sendmail")
+                               "/usr/sbin/sendmail',
+        '/usr/sbin/sendmail")))
+             #t)))))
+    (inputs
+     `(("git" ,git)
+       ("sendmail" ,sendmail)))
+    (home-page "https://github.com/git-multimail/git-multimail")
+    (synopsis "Send notification emails for Git pushes")
+    (description
+     "This hook sends emails describing changes introduced by pushes to a Git
+repository.  For each reference that was changed, it emits one ReferenceChange
+email summarizing how the reference was changed, followed by one Revision
+email for each new commit that was introduced by the reference change.
+
+This script is designed to be used as a post-receive hook in a Git
+repository")
+    (license license:gpl2)))
+
 (define-public python-ghp-import
   (package
     (name "python-ghp-import")