diff mbox series

[bug#38922] gnu: Add xcur2png

Message ID 20200104165430.18747-1-leo.prikler@student.tugraz.at
State Accepted
Headers show
Series [bug#38922] gnu: Add xcur2png | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Leo Prikler Jan. 4, 2020, 4:54 p.m. UTC
* gnu/packages/xorg.scm (xcur2png): New variable.
---
 gnu/packages/xorg.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

Nicolas Goaziou Jan. 5, 2020, 1:06 a.m. UTC | #1
Hello,

Leo Prikler <leo.prikler@student.tugraz.at> writes:

> * gnu/packages/xorg.scm (xcur2png): New variable.

Applied. I also added a copyright line for you.

Thank you!

Regards,
Brett Gilio Jan. 6, 2020, 9:25 a.m. UTC | #2
This package was signed-off by Nicolas Goaziou (cc) with commit
fe0686864dc57ecdda7ecbb318d2618ac46169ae.

Closing, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index fda61aff67..63a84bb2ef 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -6425,3 +6425,29 @@  Thai).")
     ;; by simple permissive licenses.  See the 'COPYRIGHT' file.
     (license (list license:gpl2+
                    license:expat))))
+
+(define-public xcur2png
+  (package
+    (name "xcur2png")
+    (version "0.7.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/eworm-de/xcur2png.git")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0858wn2p14bxpv9lvaz2bz1rk6zk0g8zgxf8iy595m8fqv4q2fya"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("libpng" ,libpng)
+       ("libxcursor" ,libxcursor)))
+    (synopsis "Decode X cursors")
+    (description
+     "xcur2png is a program decomposes an X cursor into a set of PNG images and
+a configuration file reusable by xcursorgen.")
+    (home-page "https://github.com/eworm-de/xcur2png")
+    (license license:gpl3+)))