diff mbox series

[bug#38897,v2] gnu: Add ghc-pointedlist.

Message ID 20200104084655.4842-1-brown121407@member.fsf.org
State Accepted
Headers show
Series [bug#38897,v2] gnu: Add ghc-pointedlist. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Alexandru-Sergiu Marton Jan. 4, 2020, 8:46 a.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-pointedlist): New variable.
---
Fix linter errors.

 gnu/packages/haskell-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Brett Gilio Jan. 7, 2020, 7:34 p.m. UTC | #1
Hi Sergiu! Pushed with 451775a5675cdf1dfb9f4503427442b21bb5041a.

Thanks! Closing.
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 03ae83d50e..3f408d60e3 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -8615,6 +8615,31 @@  system dependencies.")
 functions for the ghc-persistent package.")
     (license license:expat)))
 
+(define-public ghc-pointedlist
+  (package
+    (name "ghc-pointedlist")
+    (version "0.6.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/pointedlist/"
+             "pointedlist-" version ".tar.gz"))
+       (sha256
+        (base32
+         "16xsrzqql7i4z6a3xy07sqnbyqdmcar1jiacla58y4mvkkwb0g3l"))))
+    (build-system haskell-build-system)
+    (home-page
+     "http://hackage.haskell.org/package/pointedlist")
+    (synopsis
+     "Zipper-like comonad which works as a list, tracking a position")
+    (description
+     "A PointedList tracks the position in a non-empty list which works
+similarly to a zipper.  A current item is always required, and therefore
+the list may never be empty.  A circular PointedList wraps around to the
+other end when progressing past the actual edge.")
+    (license license:bsd-3)))
+
 (define-public ghc-polyparse
   (package
     (name "ghc-polyparse")