diff mbox series

[bug#38899,v2] gnu: Add ghc-scalpel-core.

Message ID 20200104084246.4304-1-brown121407@member.fsf.org
State Accepted
Headers show
Series [bug#38899,v2] gnu: Add ghc-scalpel-core. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Alexandru-Sergiu Marton Jan. 4, 2020, 8:42 a.m. UTC
* gnu/packages/haskell-web.scm (ghc-scalpel-core): New variable.
---
Fix linter errors.

 gnu/packages/haskell-web.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

Comments

Efraim Flashner Jan. 30, 2020, 8:58 p.m. UTC | #1
thanks. Patch pushed.
diff mbox series

Patch

diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 5888e8542e..8a96b64a5f 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -1595,3 +1595,35 @@  cookies, serving files, and more.")
     (description
      "Haskell library which exposes zero-copy sendfile functionality in a portable way.")
     (license license:bsd-3)))
+
+(define-public ghc-scalpel-core
+  (package
+    (name "ghc-scalpel-core")
+    (version "0.6.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+              "https://hackage.haskell.org/package/scalpel-core/"
+              "scalpel-core-" version ".tar.gz"))
+        (sha256
+          (base32
+            "1qf0gnidyh8zk0acj99vn6hsj37m410lrm50sqpiv1i36rpmmsqh"))))
+    (build-system haskell-build-system)
+    (inputs
+      `(("ghc-data-default" ,ghc-data-default)
+        ("ghc-fail" ,ghc-fail)
+        ("ghc-pointedlist" ,ghc-pointedlist)
+        ("ghc-regex-base" ,ghc-regex-base)
+        ("ghc-regex-tdfa" ,ghc-regex-tdfa)
+        ("ghc-tagsoup" ,ghc-tagsoup)
+        ("ghc-vector" ,ghc-vector)))
+    (native-inputs `(("ghc-hunit" ,ghc-hunit)))
+    (home-page "https://github.com/fimad/scalpel")
+    (synopsis
+      "High level web scraping library for Haskell")
+    (description
+      "Scalpel core provides a subset of the scalpel web scraping library
+that is intended to have lightweight dependencies and to be free of all
+non-Haskell dependencies.")
+    (license license:asl2.0)))