diff mbox series

[bug#38900,v2] gnu: Add ghc-scalpel.

Message ID 20200104083423.3337-1-brown121407@member.fsf.org
State Accepted
Headers show
Series [bug#38900,v2] gnu: Add ghc-scalpel. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Alexandru-Sergiu Marton Jan. 4, 2020, 8:34 a.m. UTC
* gnu/packages/haskell-web.scm (ghc-scalpel): New variable.
---
Fix linter errors.

 gnu/packages/haskell-web.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

Comments

Efraim Flashner Jan. 30, 2020, 8:59 p.m. UTC | #1
Thanks. Patch oushed.
diff mbox series

Patch

diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index cbdf7f94a3..695668c711 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -1627,3 +1627,33 @@  cookies, serving files, and more.")
 that is intended to have lightweight dependencies and to be free of all
 non-Haskell dependencies.")
     (license license:asl2.0)))
+
+(define-public ghc-scalpel
+  (package
+    (name "ghc-scalpel")
+    (version "0.6.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+              "https://hackage.haskell.org/package/scalpel/"
+              "scalpel-" version ".tar.gz"))
+        (sha256
+          (base32
+            "0jbrfcgljl8kbcwi2zqx1jp3c3dpxrkc94za44x56kcz68n89hlz"))))
+    (build-system haskell-build-system)
+    (inputs
+      `(("ghc-scalpel-core" ,ghc-scalpel-core)
+        ("ghc-case-insensitive" ,ghc-case-insensitive)
+        ("ghc-data-default" ,ghc-data-default)
+        ("ghc-http-client" ,ghc-http-client)
+        ("ghc-http-client-tls" ,ghc-http-client-tls)
+        ("ghc-tagsoup" ,ghc-tagsoup)))
+    (home-page "https://github.com/fimad/scalpel")
+    (synopsis
+      "High level web scraping library for Haskell")
+    (description
+      "Scalpel is a web scraping library inspired by libraries like Parsec
+and Perl's Web::Scraper Scalpel builds on top of TagSoup to provide a
+declarative and monadic interface.")
+    (license license:asl2.0)))