diff mbox series

[bug#38897] gnu: Add ghc-pointedlist.

Message ID 20200103162120.3936-1-brown121407@member.fsf.org
State Accepted
Headers show
Series [bug#38897] gnu: Add ghc-pointedlist. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Alexandru-Sergiu Marton Jan. 3, 2020, 4:21 p.m. UTC
* gnu/packages/haskell-xyz.scm (ghc-pointedlist): New variable.
---
 gnu/packages/haskell-xyz.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Brett Gilio Jan. 4, 2020, 4:27 a.m. UTC | #1
Alexandru-Sergiu Marton <brown121407@gmail.com> writes:

> +(define-public ghc-pointedlist
> +  (package
> +    (name "ghc-pointedlist")
> +    (version "0.6.1")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append
> +             "https://hackage.haskell.org/package/pointedlist/"
> +             "pointedlist-" version ".tar.gz"))
> +       (sha256
> +        (base32
> +         "16xsrzqql7i4z6a3xy07sqnbyqdmcar1jiacla58y4mvkkwb0g3l"))))
> +    (build-system haskell-build-system)
> +    (home-page
> +     "http://hackage.haskell.org/package/pointedlist")
> +    (synopsis
> +     "A zipper-like comonad which works as a list, tracking a position.")
> +    (description
> +     "A PointedList tracks the position in a non-empty list which works
> +similarly to a zipper. A current item is always required, and therefore
> +the list may never be empty. A circular PointedList wraps around to the
> +other end when progressing past the actual edge.")
> +    (license license:bsd-3)))

Hey again, Sergiu! I have a few suggestions for this package. I think
you forgot to run the linter :) which is okay! However, had you run it,
it would have warned you about the synopsis starting with an article,
the synopsis ending with a period, and the description not being double
spaced after each sentence punctuation. If you could reroll a V2 for
this, I would appreciate it!

Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 03ae83d50e..835380a69e 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -8615,6 +8615,31 @@  system dependencies.")
 functions for the ghc-persistent package.")
     (license license:expat)))
 
+(define-public ghc-pointedlist
+  (package
+    (name "ghc-pointedlist")
+    (version "0.6.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://hackage.haskell.org/package/pointedlist/"
+             "pointedlist-" version ".tar.gz"))
+       (sha256
+        (base32
+         "16xsrzqql7i4z6a3xy07sqnbyqdmcar1jiacla58y4mvkkwb0g3l"))))
+    (build-system haskell-build-system)
+    (home-page
+     "http://hackage.haskell.org/package/pointedlist")
+    (synopsis
+     "A zipper-like comonad which works as a list, tracking a position.")
+    (description
+     "A PointedList tracks the position in a non-empty list which works
+similarly to a zipper. A current item is always required, and therefore
+the list may never be empty. A circular PointedList wraps around to the
+other end when progressing past the actual edge.")
+    (license license:bsd-3)))
+
 (define-public ghc-polyparse
   (package
     (name "ghc-polyparse")