diff mbox series

[bug#38893] gnu: make-bootstrap: Add cross-libc:static to the inputs.

Message ID 20200103143010.15985-1-m.othacehe@gmail.com
State Accepted
Headers show
Series [bug#38893] gnu: make-bootstrap: Add cross-libc:static to the inputs. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Mathieu Othacehe Jan. 3, 2020, 2:30 p.m. UTC
This is a follow-up of 4610ab7c9a5327df0d475262817bc081a5891aa8. 'getpw' & co
fail with a cross-compiled statically-linked guile.

* gnu/packages/make-bootstrap.scm (package-with-relocatable-glibc)[inputs]:
Add "cross-libc:static".
---
 gnu/packages/make-bootstrap.scm | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

Comments

Ludovic Courtès Jan. 15, 2020, 9:10 p.m. UTC | #1
Hello,

Mathieu Othacehe <m.othacehe@gmail.com> skribis:

> This is a follow-up of 4610ab7c9a5327df0d475262817bc081a5891aa8. 'getpw' & co
> fail with a cross-compiled statically-linked guile.
>
> * gnu/packages/make-bootstrap.scm (package-with-relocatable-glibc)[inputs]:
> Add "cross-libc:static".

Good catch, LGTM!

Thanks,
Ludo’.
Mathieu Othacehe Jan. 16, 2020, 9:17 a.m. UTC | #2
Hey,

>> * gnu/packages/make-bootstrap.scm (package-with-relocatable-glibc)[inputs]:
>> Add "cross-libc:static".
>
> Good catch, LGTM!

Thanks for reviewing, pushed on core-updates!

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index d149a7ec1a..0144a6e9a2 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -5,6 +5,7 @@ 
 ;;; Copyright © 2018, 2019 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2018, 2019 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
 ;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2020 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -137,7 +138,10 @@  for `sh' in $PATH, and without nscd, and with static NSS modules."
   (define (inputs)
     (if (%current-target-system)                ; is this package cross built?
         `(("cross-libc"
-           ,(cross-bootstrap-libc (%current-target-system))))
+           ,(cross-bootstrap-libc (%current-target-system)))
+          ("cross-libc:static"
+           ,(cross-bootstrap-libc (%current-target-system))
+           "static"))
         '()))
 
   (define (native-inputs)