diff mbox series

[bug#38877] gnu: Add xcur2png.

Message ID 20200102202336.20617-1-leo.prikler@student.tugraz.at
State Accepted
Headers show
Series [bug#38877] gnu: Add xcur2png. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Leo Prikler Jan. 2, 2020, 8:23 p.m. UTC
* gnu/packages/xorg.scm (xcur2png): New variable.
---
 gnu/packages/xorg.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

Brett Gilio Jan. 4, 2020, 4:32 a.m. UTC | #1
Leo Prikler <leo.prikler@student.tugraz.at> writes:

> * gnu/packages/xorg.scm (xcur2png): New variable.
> ---
>  gnu/packages/xorg.scm | 26 ++++++++++++++++++++++++++
>  1 file changed, 26 insertions(+)
>
> diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
> index fda61aff67..1c21a1cf86 100644
> --- a/gnu/packages/xorg.scm
> +++ b/gnu/packages/xorg.scm
> @@ -6425,3 +6425,29 @@ Thai).")
>      ;; by simple permissive licenses.  See the 'COPYRIGHT' file.
>      (license (list license:gpl2+
>                     license:expat))))
> +
> +(define-public xcur2png
> +  (package
> +    (name "xcur2png")
> +    (version "0.7.1")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/eworm-de/xcur2png.git")
> +                    (commit version)))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +                "0858wn2p14bxpv9lvaz2bz1rk6zk0g8zgxf8iy595m8fqv4q2fya"))))
> +    (build-system gnu-build-system)
> +    (synopsis "Decode X cursors")
> +    (description
> +     "xcur2png is a program decomposes an X cursor into a set of PNG images and
> +a configuration file reusable by xcursorgen.")
> +    (native-inputs
> +     `(("pkg-config" ,pkg-config)))
> +    (inputs
> +     `(("libpng" ,libpng)
> +       ("libxcursor" ,libxcursor)))
> +    (home-page "https://github.com/eworm-de/xcur2png")
> +    (license license:gpl3+)))

Hey Leo! It doesn't really matter all that much, but I am curious about
the ordering of the package declaration. Why did you put the inputs
/after/ the synopsis and description? It's a fine looking package otherwise!
diff mbox series

Patch

diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index fda61aff67..1c21a1cf86 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -6425,3 +6425,29 @@  Thai).")
     ;; by simple permissive licenses.  See the 'COPYRIGHT' file.
     (license (list license:gpl2+
                    license:expat))))
+
+(define-public xcur2png
+  (package
+    (name "xcur2png")
+    (version "0.7.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/eworm-de/xcur2png.git")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0858wn2p14bxpv9lvaz2bz1rk6zk0g8zgxf8iy595m8fqv4q2fya"))))
+    (build-system gnu-build-system)
+    (synopsis "Decode X cursors")
+    (description
+     "xcur2png is a program decomposes an X cursor into a set of PNG images and
+a configuration file reusable by xcursorgen.")
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("libpng" ,libpng)
+       ("libxcursor" ,libxcursor)))
+    (home-page "https://github.com/eworm-de/xcur2png")
+    (license license:gpl3+)))